VLC spielt bei MP4-Dateien nur Ton ab, Bildschirm bleibt schwarz

    VLC spielt bei MP4-Dateien nur Ton ab, Bildschirm bleibt schwarz

    Hallo!

    Ich bin langjähriger VLC-Nutzer, und leider lässt mich das Programm gerade jetzt im Stich, wo ich es dringend für meine Arbeit brauche.

    Das Problem: Ich will mp4-Dateien abspielen, deren Inhalte ich protokollieren muss. Wenn ich diese Dateien (auf welche Weise auch immer) mit VLC starten will, dann werden sie geladen, aber es wird nur der Ton abgespielt - der Bildschirm bleibt erst mal schwarz.

    Ansonsten passiert im Bildschirmbereich noch dies: Wenn ich nach diesem Video-Dateiaufruf einen Mouse-Over über den Zeitschieberegler mache, dann bleibt ein "Geist" der Zeitanzeige im Bildschirmbereich von VLC hängen; und wenn ich zwischen verschiedenen Programmfenstern hin und her schalte, dann bleibt im VLC-Bildschirmbereich sowas wie ein "Foto-Ausschnitt" des vorherigen Programmfensters hängen (und kann auch zusammen mit dem VLC-Fenster hin und hergezogen werden). Habe dieser Anfrage einen Screenshot der VLC-Benutzeroberfläche beigegeben.

    Als ich VLC das letzte Mal auf diesem System für mp4-Dateien eingesetzt habe, gabs noch kein Problem; habe seitdem (bis heute, wo ich es mit Neu-Aufspielen versucht habe) auch nicht das Geringste an den Einstellungen geändert. (Vielleicht habe ich VLC seitdem aber auch auf 2.0 ge-üpdätet - da bin ich mir jetzt doch nicht ganz sicher...)

    Mein System ist Win 7 Starter, 32 bit, SP1. Ich habe VLC 2.0.3 (also die aktuelle Version). Habe mir VLC heute schon zweimal neu aufgespielt, einmal ohne und einmal mit Löschung von Einstellungen und Cache - Problem ist geblieben.

    Ich bin nur ein "kenntnisreicher Laie" und kein großer Computer-Crack. Außerdem habe ich gerade wichtige Projektarbeit um die Ohren, so dass ich jetzt zur Problemlösung leider auch keine großen Test- und Versuchsreihen durchführen kann.

    Vielleicht hat jemand von Euch Verständnis dafür und will mir helfen, VLC wieder zum Laufen zu bringen? Derzeit benutze ich zum Notbehelf den Windows Media Player, wo die mp4-Dateien einwandfrei funktionieren. Aber ich vermisse den Komfort von VLC mit seiner schnellen Tastaturbedienung usw., und das Rumgepfriemel mit dem allzu kindgerecht gestalteten Media-Abdudler von Microsoft kostet dauernd Nerven und Zeit.

    Vielleicht fehlen mir ja irgendwelche, wie heißen die Dingsens, Codecs oder weiß der Kuckuck? Nur so ein Gedanke.

    Vielen Dank schon mal, & Grüße!

    Pretzel
    Bilder
    • VLC-Problem.png

      23,34 kB, 484×332, 32 mal angesehen

    Problem gelöst, Patient tot

    Da hier - wie bei den meisten anderen Hilfesuchenden - keiner geantwortet hat und wohl auch keiner antworten wird, habe ich mich auch im englischen VLC-Forum umgetan.

    Nun hat sich das Problem allerdings mehr oder weniger erledigt: ich habe selbst rausgefunden, dass hier eine grundsätzlicher Mangel des VLC-Players vorliegt. Damit es hier wenigstens noch zu sowas wie einer Problemlösung kommt, ohne dass ich noch viel Zeit verliere: hier mein "Lösungs"-Eintrag, wie ich ihn ins englische Forum gestellt habe:

    I was just about to post the log when I found out the probable cause (in some other forum, didn't save the link):

    It seems that VLC can't process a certain subset of H264-MP4 files, and I assume my files belong to that set. My log says stuff like:

    Quellcode

    1. main warning: picture is too late to be displayed (missing 814 ms)
    2. main warning: picture is too late to be displayed (missing 708 ms)
    3. main warning: picture is too late to be displayed (missing 677 ms)
    4. main warning: picture is too late to be displayed (missing 467 ms)
    5. main warning: picture is too late to be displayed (missing 436 ms)
    6. avcodec error: more than 5 seconds of late video -> dropping frame (computer too slow ?)

    ... which is utter BS cause with other players the computer is totally up to it; and the MP4s that are causing all the trouble are just semi-static slide shows, while my computer can play even high definition (as well as highly compressed) MP4 movies with no lag at all.

    Possible solutions:

    - Wait until VLC has reached the next stage in its development -> not an option here.
    - Install a codec set like K-Lite and use it with VLC. General advice on tech pages: that can mean big trouble if not properly installed, up to -> Format C:\ . Do it only if you know what you're doing. I don't, so I didn't.
    - Use the Windows Media Player which can handle these files. But its clumsy, mouse-centered UI really spoils it all.

    I settled for:

    - Use the AVS Media Player. Perfectly up to the task, and perfectly usable with simple keyboard shortcuts, just like VLC.

    But it's not open source, it's not VLC. Hope you programmer guys will solve the problem soon, cause I'd really like to stick with yours!

    Greetings from

    El Pretzel


    Ja, in diesem Sinne...!

    Patient lebt doch noch: die Lösung

    Damit auch die deutschen Hilfesuchenden nach mir was davon haben - hier die tatsächliche Problemlösung aus dem englischen Forum:


    "Lotesdelere" schrieb:



    (...) Disable/enable GPU acceleration:
    wiki.videolan.org/WindowsFAQ-2…k_is_full_of_image_errors
    (...)



    Thanks, Lotesdelere - that did the job!

    It was your third point: "And/or disable/enable GPU acceleration" - I had to enable it!

    You can also try to enable/disable GPU decoding, and see if it helps. It can be found from Tools -> Preferences and Input & Codecs and tick/untick Use GPU accelerated decoding. Remember to press Save to save VLC settings and restart VLC after that to make sure changes are enabled.

    My MP4s are now working flawlessly.

    => Back to VLC; back to open source; back to computing as it should be.

    Thanxalot :)

    PS. I'll post this also in the German VLC forum: one of the few problems there that ever got solved. That's the least thing I can do for the community ...

    :!: Keep on the good work :!:

    t'Pretzel

    Und hier auf deutsch, zum Mitschreiben:

    Man ändert die Einstellung "GPU-beschleunigte Decodierung": Extras -> Einstellungen und Input & Codecs: An- oder Wegticken von "Nutze die GPU-beschleunigte Decodierung". Danach auf Speichern drücken und den VLC-Player neustarten, damit die geänderte Einstellung auch sicher angewendet wird.