Video mit Untertitel konvertieren

  • Ich habe eine Frage.
    Ich kann einen Film abspielen und sehe auch Untertitel, die aus einer externen Datei aufgerufen werden.
    Nun habe ich versucht, das aufzuzeichnen, in der Hoffnung, dass die Untertitel im Film implementiert werden.
    Das war zu laienhaft gedacht. Leider funktioniert das nicht.


    Gibt es im VLC Möglichkeiten?


    Danke.


    XP SP3, VLC 2.13, Datei = .ass hergestellt mit Aegisub.

  • Hallo kodela,


    ich habe diesbezüglich schon viel ausprobiert, aber so richtig ist mir das nicht gelungen.
    Im VLC habe ich eigentlich den Film abgespielt, vorher die Untertiteldatei ausgesucht.
    Die Untertitel waren auch da, allerdings bei der Aufnahme des Films dann nicht.


    Mit Konvertieren habe ich noch nicht probiert, da ich derzeit im familiären Bereich andere Sorgen habe.
    Ich hatte die .ass Datei schon mal in eine .sup umgewandelt und wollte das mit IFOEdit machen. Der nimmt sie zwar, aber er tut damit nichts.


    Ich will einen selbst erstellten Untertitel so in einen Film brennen, dass ich die Datei z.B. nach .FLV konvertiere und diese anderen Leuten zur Verfügung stelle. Aber das ist augenscheinlich gar nicht so einfach.

  • Mit Konvertieren habe ich noch nicht probiert, ...


    Hallo Oldware,


    Wie soll es denn sonst gehen? Damit man die Untertitel in das Video bekommt, muss man es doch völlig neu kodieren. Bei der Gelegenheit kannst Du das konvertierte Video auch in einen FLV-Container packen lassen. Das alles ist sogar ziemlich einfach.


    MfG, kodela

  • Das tut nicht.


    Ich habe einen Film (.avi) eingefügt, ich habe eine x-beliebige (.srt-Datei) aus dem Internet zugefügt und es in ein anderes Format (.ts) konvertiert.
    Keine Untertitel.


    Falls so etwas doch gehen sollte, dann stimmt vielleicht das Format der Untertitel nicht.

  • Hallo Oldware,


    ich habe keine Ahnung, welche Version des VLC Du verwendest, vermutlich eine Rincewind-Version, also 2.1.x. Damit ist es mir auch nicht gelungen, die Untertitel einzubinden. Mit der Version 2.0.8, die ich für meine eigenen Zwecke noch immer verwende, habe ich dagegen keine Probleme. Daher meine Empfehlung, gehe zurück zur Version 2.0.8.


    Probiere auch zuerst einmal die Konvertierung nach MP4 und dann nach FLV. Wenn es mit MP4 funktioniert, mit FLV dagegen nicht, dann konvertiere in zwei Schritten, im ersten nach MP4 und damit die Untertitel einbinden, anschließend nach FLV, wobei die Originalvieo- und Audiospur beibehalten werden können.


    Für die Verkapselung solltest Du allerdings auf keinen Fall eine Transportstream (TS) verwenden. Dieser Container ist, wie es der Name bereits sagt, für den Transport oder dem Transfer eines Videos und nicht für die Anlage einer Datei bestimmt.


    MfG, kodela

  • Ja, ich benutze die aktuelle Version.
    Ich habe bisher da nur rumgespielt.
    Eine .srt-Datei ist eigentlich nur Text, keine Steuerzeichen, nur die Zeiten und der Text.
    Vielleicht ist das die Ursache.
    Eine .ass-Datei sieht schon ganz anders aus.


    Aber ich habe für mich eine elegantere Lösung gefunden.
    Die Filme, die ich subtiteln wollte, gibt es inzwischen deutsch übersetzte, allerdings werden manche Passagen nicht übersetzt. Das sind Passagen, in denen Eingeborenensprache verwendet wird. Dort sind nur englische Subtitles.
    Aber, die englische Version mit Untertiteln überschreibt diese Passagen mit deutschen Untertiteln. Nun mixe ich die Filme einfach.


    Das sind qualitativ keine hochwertigen Filme, deswegen geht das auch.


    Danke für Deine Hilfe, kodela. Ich weiß das zu schätzen.

  • Hallo Oldware,


    bist Du auch so vorgegangen, wie ich es hier beschrieben habe?


    Es muss funktionieren. Ich habe es unter allen nur denkbaren Kombinationen getestet, immer erfolgreich.


    Als Ausgangsvideos habe ich alle mir zur Verfügung stehenden Videos verwendet und als Untertiteldatei die einfache SRT-Variante, aber auch die SSA-Variante. Dabei habe ich die Konvertierung mit kurzen aber auch langen Untertiteldateien vorgenommen.


    Hier ein Beispiel in der allereinfachsten Testvariante, der Inhalt von test.srt:


    Code
    1. 1
    2. 00:00:01,000 --> 00:00:08,000
    3. Dies ist ein Testvideo


    Ich frage deshalb, funktioniert bei Dir eine Konvertierung ohne die Untertitel?


    MfG, kodela

  • Hallo kodela,


    ich habe Folgendes gemacht:


    1. Medien >> Konvertieren/Speichern ------- (Medien öffnen-Menü öffnet)
    2. Datei >> Hinzufügen... ----------- (Datei mit dem Browser gesucht und eingefügt)
    3. Häkchen gesetzt >> Eine Untertiteldatei benutzen --- (Datei gesucht und eingesetzt) (Datei hat dasselbe Format wie dein Quellcode)
    4. Konvertieren/Speichern gedrückt (Konvertieren-Popup öffnet)
    5. In dem Profil (MP4) das Werkzeug geklickt.
    6. Profil ändern öffnet.
    7. Untertitel geklickt >> Häkchen bei Untertitel über das Video legen. (Habe den Prozess auch ohne diese Option probiert)
    8. Zieldatei ausgesucht und gestartet.
    9. Fertige Datei mit VLC aufgerufen, keine Untertitel im Film.


    Und was bitte mache ich nun falsch?
    Außer mit der Maus klicken kann ich eigentlich nichts machen.

  • Hallo Oldware,


    Du möchtest wissen, was Du falsch machst. Nun gut, Dein Fehler ist, dass Du mehr machst, als ich es Dir beschrieben habe. Ich zitiere mich einmal selbst:


    Quote

    Medien - Konvertieren/Speichern... und dann Eine Untertiteldatei benutzen,


    Steht da irgend etwas davon, dass Du bei den Profileinstellungen "Untertitel" anklicken sollst?


    Konvertiere mit 2.0.8 ohne bei den Profileinstellungen im Tab "Untertitel" etwa zu selektieren!


    MfG, kodela

  • Tut mir leid, aber bei mir funktioniert es nicht.


    8oxNbcbH8P2l.jpg


    f7x5AdKpM5ez.jpg


    NS9mWuq9ZuyR.jpg


    Jetzt habe ich es noch einmal gemacht und dabei "Ausgabe anzeigen" angeklickt.
    Mit dieser Option startet der Film, bleibt aber beim ersten Bild bis zum Ende stehen.
    Allerdings zeigt er den ersten Teil von den Untertiteln an.
    Später im Film ist aber nichts mehr drin.


    Was auch immer Du machst, bei mir geht es nicht. Woodoo aus LL :D

  • Hallo Oldware,


    bin zur Zeit unterwegs und habe es mit eingeschränkten Möglichkeiten hier wo ich gerade bin versucht. Dabei ging es mir wie Dir!


    Wenn ich Ende der Woche wieder meine Umgebung zur Verfügung habe, werde ich alles noch einmal gründlich durchtesten und mich dann wieder melden.


    Im Augenblick ist mir nur aufgefallen, dass Du mein Testbeispiel als ass- und nicht als srt-Datei gespeichert hast. Daran darf es aber nicht liegen.


    Und noch eine Frage: Das erste Bild von Dir hat ja den Untertitel aus der Datei. Ist dieses Bild entstanden, als das Video bei der Transkodierung auch angezeigt werden sollte?


    MfG, kodela

  • Hallo kodela,


    es geht nicht mit dem VLC. Ich habe auch im Internet nirgends etwas über die Möglichkeit mit VLC gefunden.
    Die .srt-Datei habe ich mit Aegisub erstellt. Das würde schon funktionieren.


    Inzwischen habe ich mir AutoGK (Auto Gordian Knot) installiert. Damit habe ich das einwandfrei hingekriegt.
    Source: die obige AVI-Datei und das Ergebnis war auch .AVI.
    Es dauert zwar, weil da zwei Durchläufe stattfinden, aber es funktioniert.


    Ich danke für Deine Hilfe.


    Bis denne
    Oldware

  • Hallo Oldware,


    glaube mir, es geht. Ich habe mindestens zwanzig Konvertierungen in Folge erfolgreich getestet. Dabei habe ich zum Beispiel auch festgestellt, dass es bei einer Aktivierung der Untertiteloption im Profil (bei mir) nicht funktioniert. Wenn ich unter ansonsten identischen Einstellungen ohne dieser aktivierten Option konvertierte, waren die Untertitel im Video.


    Ich bin zwar im Augenblick etwas überrascht und verblüfft, aber ich habe nicht einfach etwas geschrieben, was ich nicht gründlich getestet worden ist.


    Für Dich ist natürlich wichtig, dass es funktioniert und wenn Du mit "AutoGK" keine Probleme hast, dann muss es ja auch nicht der BLC sein.


    MfG, kodela

  • Hallo,


    dass es zumindest mit den Rincewind Versionen Probleme mit dem Einbinden von Untertiteln gibt, ist aus einer Antwort vom VideoLAN-Präsidenten zu einer diesbezüglichen Frage im VideoLAN Forum ersichtlich:


    Quote

    by Jean-Baptiste Kempf » Wed Dec 11, 2013 12:30 am


    Use makemkv to embed a srt inside a video file.


    Er empfiehlt für diesen Zweck damit ein externes Programm.


    kodela

  • Ich habe nun mehr oder minder den ganzen Nachmittag damit verbracht, mit AutoGK Untertitel einzubinden.
    Es ist mit einer .srt-Datei schwierig, die genauen Schnitte zu finden, obwohl ich versucht habe, mit mpeg2Schnitt auf ein Tausendstel genau die Punkte zu finden.
    Allerdings habe ich danach verwundert den Film angeschaut und alle Untertitel waren doppelt, also mit Echo. ;O))
    Was ich bis dato nicht wusste, VLC schaltet automatisch bei der Wiedergabe die Untertitelspur (Unterspur) zu.
    Also muss im .avi-File noch ein Stream drin sein, der dieses veranlasst.

  • Hallo Oldware,


    wenn Du in einem Ordner die Videodatei XYZ.avi und dazu die Untertiteldatei XYZ.srt hast, dann wird der VLC, wenn Du über ihn die Videodatei wiedergibst, auch die Untertitel der entsprechenden Datei einblenden. Wenn dann im Video bereits die Untertitel sind, dann bekommst Du das Echo, wie Du es nennst.


    Über die Menüoption Video - Untertitelspur kann man aber auch eine Untertiteldatei mit ganz anderem Namen einbinden.


    MfG, kodela

  • Hi kodela,


    ich denke, ich habe mich falsch ausgedrückt.
    Die .srt war nicht mehr vorhanden.


    Ich hatte die Untertiltel fest in die .avi eingebrannt. Dennoch wurden die Untertitel doppelt angezeigt. Aber woher.


    Die Lösung ergab ein Blick in die Codecs-Informationen.
    Stream 0 = Video
    Stream 1 = Audio
    und nun noch
    Stream 2 (das waren die Untertitel)


    Sie waren nicht nur im Video eingebrannt, sondern auch noch als Stream vorhanden. Und das hat der VLC gemerkt und die Option eingeschaltet.