Kommandozeile ... Inhaltstext: Mikrofonaufnahme

  • Bin grade dabei mich durch die o.g. Empfehlung zuarbeiten. Bin im o.g. Teil "Mikrofonaufnahme".
    Mir will das genaue Nachvollziehen nicht gelingen, wo es doch so einfach sein müßte.


    (Mein System: Win 7 pro, VaioNotebook mit genau dem zitierten Realtek Mikrofon, VLC 2.2.1. 64bit.)


    A) Ich stoße mich bereits an der Tatsache, wie ich (in der GUI) zum "Aufnahmegerät" komme, weil es ja mindestens 3 verschiedene Wege gibt:
    a. Menü: Medium öffnen-Zunge Aufnahmegerät öffnen
    b. Menü: Aufnahmegerät öffnen
    c. Menü: Stream-Zunge Aufnahmegerät öffnen


    Frage 1: Sind diese differenten Wege gleichwertig oder ist da etwas differentes zu beanchten?


    B) "Über die Taste Stream gelangt man zum Dialog Streamausgabe. Dort wird der MRL für die Quelle angezeigt und man geht über die Taste Next weiter zur Zieleinstellung."
    Ich gehe also über stream und next= "Nächstes" weiter und komme zur Exportdateiauswahl.


    Hier aber kann ich aber kein .mp3 benennen. Es sind mir eine feste Containerauswahl vorgegeben und mp3 gehört nicht dazu!
    Ich kann zwar eine datei.mp3 zum Speichern vorgeben, aber nach der Profilgestaltung (container=ts, video=none, audio=mp3) kommt als
    Kommandozeilenstring dennoch ein .ts zum Vorschein!


    Frage 2: Wie soll ich nun die Empfehlung am besten nachvollziehen? Soll ich analog zur Beschreibung ein anderes Profil nehmen? Oder gar eine
    andere VLC-Version? Dann wäre aber dieses Beispiel (ohne einen einschränkenden Hinweis zum Degrading von VLC) nicht gut geeignet.


    Danke für Diskussion

  • Hallo Pit,


    ja, die drei von Dir aufgezeigten differenten Wege sind grundsätzlich gleichwertig, für den weiteren Ablauf jedoch nicht identisch. Ich will versuchen, es mit einem Beispiel zu erklären:


    Der VLC soll das Signal vom Mikrofoneingang ins Heimnetz streamen, so dass es über alle angeschlossenen Geräte empfangen werden kann. In einem Firmennetzwerk sollen so gesprochene Durchsagen des Chefs von allen Abteilungen Durchsagen empfangen werden können.

    • Der Chef könnte dazu über Menü - Medien - Medium öffnen ... das Dialogfenster Medien öffnen öffnen, hier das Registerblatt Aufnahmegerät öffnen selektieren, das Mikrofon als solches auswählen und über die Listenschaltfläche, die auf Wiedergabe eingestellt ist, die Option Stream zu selektieren. Den Rest spare ich mir.
    • Er könnte auch über Menü - Medien - Aufnahmegerät öffnen ... zum Dialogfenster Medien öffnen kommen, bräuchte das Registerblatt nicht zu wechseln und könnte weiter so vorgehen, wie vorstehend beschrieben.
    • Schließlich könnte er auch über Menü - Medien - Stream ... zum Dialogfenster Medien öffnen kommen, bräuchte das Registerblatt ebenfalls nicht zu wechseln und könnte nach der Auswahl des Mikrofons durch eine Klick auf die bereits erwähnte Listenschaltfläche, die jetzt Stream anzeigt, die weiteren Einstellungen vornehmen.
    • Es gibt noch eine vierte Möglichkeit. Über Menü - Medien - Konvertieren/Speichern ... käme man auch an das Ziel. Es führen eben viele Wege nach Rom, aber nur einer ist der kürzeste, in unserem Fall der dritte.

    Zu Deiner nächsten Frage muss ich bekennen, dass ich in der Beschreibung, auf die Du Dich beziehst, nach dem Motto "der Zweck heiligt die Mittel" vorgegangen bin und deshalb für die Erklärung, wie der VLC bei dem Zusammenstellen einer Kommandozeile hilft, nicht immer den kürzesten Weg gegangen bin. Dieser wäre im Fall einer Mikrofonaufnahme über die GUI die von Dir übersehene vierte Variante gewesen. Aber über Menü - Medien - Konvertieren/Speichern ... bekommt man leider nicht gezeigt, wie der dafür generierte Stream-Ausgabe-String aussieht und den braucht man, soll die Aufgabe über die Kommandozeile erledigt werden.


    Versuche einmal eine Mikrofonaufnahme über den vierten Weg, also über Menü - Medien - Konvertieren/Speichern ... und Du wirst sehen, die Namenserweiterung ".mp3" wird angenommen. Gehst Du dagegen über den dritten Weg, (was Du auch könntest, wenn Du den Dialog Medien öffnen über die Option Konvertieren und nicht über Stream der Listen-Schaltfläche verlassen würdest) dann geht der VLC zu Recht davon aus, dass die Aufzeichnung als Stream erfolgen soll. Damit kann die Aufzeichnung noch während aufgezeichnet wird geöffnet und wiedergegeben werden.


    Frage: Was meinst Du mit "einschränkenden Hinweis zum Degrading von VLC"?


    MfG, kodela

  • Zum zweiten zuerst: "Einschränkender Hiweis...". Ich vermeinte, dass Du hier wiederholt darauf hingewiesen hast, dass man eine frühere Version vom VLC nehmen sollte... Also ein degrading empfohlen hattest. Sollte das auch in diesem Falle so sein, dann wäre ein Hinweis spätestestend an dieser Stelle angebracht, bevor man sich auf eine Irrfahrt begibt.


    Zum ersten zurück. Mir will die mp3-Mikroaufzeichnung auf diese Weise in keinem Falle gelingen! Kann aber an meiner Hardware liegen, denn in irgendeinem verzweifelten Schritt habe ich es geschafft, eine Datei mit Inhalt zu erhalten, als ich versuchte als "wav" aufzuzeichnen. Herausgekommen ist eine "mikrofon.wav", die sich im Mediainfo als PCM (44,1 kHz , 2 channels) entpuppte. mp3 mit Inhalt ist mir wie gesagt nicht geglückt.

  • Ich vermeinte, dass Du hier wiederholt darauf hingewiesen hast, dass man eine frühere Version vom VLC nehmen sollte... Also ein degrading empfohlen hattest.


    Hallo Pit,


    ein generelles Degrading habe ich sicher nie empfohlen. Richtig ist aber, dass ich immer wieder, so auch heute zum Beispiel in einem Beitrag von mir geschrieben habe, dass diese oder jene Funktionalität nur über eine Vorgängerversion erreichbar ist. Bei besonders anfälligen Versionen, zum Beispiel 2.1.0, habe ich sogar generell empfohlen, zur Version 2.0.8 zurück zu gehen.


    Zurück zur Mikrofonaufnahme über einen Kommandozeilenstring. Damit ich nichts behaupte, was dann nicht stimmt, habe ich eben unter der Version 2.2.1 (eine ziemlich stabile Version übrigens) zwei Mikrofonaufnahmen über eine Batchdatei gemacht. Hier die beiden Strings:


    START vlc --qt-start-minimized --sout-file-format dshow:// --sout=#transcode{vcodec=none,acodec=mp3,ab=256,channels=2,samplerate=48000}:file{dst=D:\\VLC\\Aufnahmen\\MA_%%Y%%m%%d%%H%%M%%S.mp3}


    und


    START vlc --qt-start-minimized --sout-file-format dshow:// --sout=#transcode{vcodec=none,acodec=s16l,ab=256,channels=2,samplerate=48000}:file{dst=D:\\VLC\\Aufnahmen\\MA_%%Y%%m%%d%%H%%M%%S.wav}


    Beide Strings haben zu einwandfreien Aufnahmen geführt, einmal im MP3- und einmal im WAV-Format. Die Strings können natürlich noch etwas schlanker gemacht werden. Damit könnte ein solcher String zum Beispiel auch so aussehen:


    vlc dshow:// --sout=#transcode{vcodec=none,acodec=s16l,ab=256,channels=2,samplerate=48000}:file{dst=D:\\VLC\\Aufnahmen\\MAufnahme.wav}


    Das müsste auch bei Dir funktionieren.


    Hinweis: Ich habe bei mir den Pfad für den Aufruf des VLC als Umgebungsvarible gesetzt. Daher genügt bei meinen Kommandozeilenstrings ein einfaches "vlc" für den Aufruf von vlc.exe.


    MfG, kodela

  • Weiß nicht sicher, was bei mir früher nicht funktionierte, denn mit der von Dir empfohlenen "ab=256" konnte ich schließlich doch mp3 erzielen.
    Die beiden wav-Beispiele produzieren bei mir jeweils PCM laut mediainfo, aber hören kann man das schon korrekt.
    Ich habe keine path-Umleitung, weil sich meine Sicherheitssoftware ein wenig ziert und ich nicht mehr viel rumbiegen wollte.
    Auch habe ich nicht mit start gearbeitet, denn mich stört das Fenster nicht.


    ABER:
    1) --qt-start-minimized wird egal ob mit oder ohne start abgelehnt. Da ist wohl ein wurm drin...
    2) Ich weiß nicht wie Du die %%Y usw. reinbekommst. Bei mir werden die als Zeichen interpretiert. Unter meinem win7 (64 bit) werden die nicht als Datumsbestandteile interpretiert. Muß man da noch was vereinbaren? Bin wohl auf dem Schlauch.


    Danke bisher... wie immer der Beste...

  • Hallo Pit,


    dass es mit der Aufnahme im MP3-Format lag, hat nicht mit der Bitrate (ab=256) zu tun. Du kannst hier auch, wenn die Qualitätsansprüche nicht dagegen stehen, ein Bitrate von 128 oder noch niedriger setzen.


    Der Rest müsste eigentlich auch funktionieren. Setze vorsichtshalber einmal alle Einstellungen und den Cache für den VLC auf die Defaultwerte zurück. Das Vorgehen dafür ist im Thema Alle Einstellungen zurücksetzen beschrieben.


    Was meinst Du mit "Ich weiß nicht wie Du die %%Y usw. reinbekommst."? So sieht bei mir die Kommandozeile einer Batchdatei aus. Mit der Zeichenfolge %%Y%%m%%d%%H%%M%%S wird veranlasst, dass die Datei einen eindeutigen Namen bekommt, der von keiner späteren Aufnahme mehr überschrieben werden kann. Normalerweise müsste das so aussehen: "%Y%m%d%H%M%S", wobei %Y für die Jahreszahl, %m für den Monat, %d für den Tag, %H für die Stunde und %S für die Sekunde des Aufnahmestarts steht. In Batchdateien muss aber, damit diese Zeichen richtig interpretiert werden, vor einem Prozentzeichen ein weiteres Prozentzeichen stehen.


    Poste doch einmal, wie so eine Batchdatei bei Dir aussieht.


    MfG, kodela

  • Meine cmd (in einer Zeile natürlich):


    Code
    "c:\Program Files\VideoLAN\VLC\vlc" dshow:// --sout=#transcode{vcodec=none,acodec=mp3,ab=256,channels=2,samplerate=48000}:file{dst=C:\\Users\\Peter\\VLC\\MA_%%Y%%m%%d%%H%%M%%S.mp3}


    Das Resultat im Explorer dann:


    MA_%Y%m%d%H%M%S


    (in der Liste wird das .mp3 nicht angezeigt, aber man bekommt es unter Typ oder auf der Kommandozeile zu sehen)


    Noch habe ich die Einstelllungen nicht zurückgesetzt...
    Pit

  • Hallo Pit,


    ich verstehe nicht, wie Du zu diesem String gekommen bist:


    Code
    "c:\Program Files\VideoLAN\VLC\vlc" dshow:// --sout=#transcode{vcodec=none,acodec=mp3,ab=256,channels=2,samplerate=48000}:file{dst=C:\\Users\\Peter\\VLC\\MA_%%Y%%m%%d%%H%%M%%S.mp3}


    Du hast hier einfach einen Mix aus zwei von mir gezeigten Strings gemacht. So einfach geht das aber nicht, denn alles hat seine Bedeutung.


    In meinem ersten Beispielstring ist der Parameter --sout-file-format enthalten und der Dateiname wird als Formatstring so gebildet: Aufnahmen\\MA_%%Y%%m%%d%%H%%M%%S.mp3.


    Und Du übernimmst für den Dateinamen den Formatstring aber nicht den Parameter --sout-file-format, welcher den VLC anweist, die Prozentzeichen mit den nachfolgenden Buchstaben als Formatierungszeichen zu behandeln und dann wunderst Du Dich, wenn er im Dateinamen an Stelle des Zeitcodes die Prozentzeichen mit den nachfolgenden Buchstaben verwendet.


    In meinem abgespeckten Beispiel habe ich auf den Parameter --sout-file-format und im Dateinamen auf die Formatzeichen verzichtet.


    Du solltest übrigens unbedingt im Register Ansicht in den Ordneroptionen des Explorers (erreichbar über Alt-Taste - Menüoption Extras) in der Liste der erweiterten Einstellungen bei der Option Erweiterungen bei bekannten Dateitypen ausblenden das Häkchen entfernen. Damit siehst Du auch die Namenserweiterungen bei den Dateien. Ohne diese ist ein vernünftiger Umgang mit den Dateien nicht möglich.


    MfG, kodela

  • Ich wußte es, früher! Aber hatte das vergessen, das zweite (Explorer) war mir bisher nicht wichtig. Aber es stimmt, auch das ist zweckmäßiger.
    Danke für die Empfehlung. Bin jetzt extrem müde und muß ins Bett...


    Danke nochmals für die Durchsicht!

  • Habe jetzt alles so, wie Du empfohlen hattest, also sogar --qt-start-minimized und es hat geklappt


    Aufgefallen ist mir nur noch, dass Du unter samplerate im 2. Beispiel 48000l schriebst. Ich hatte, weil kopiert, das auch in meinen Versuchen und bin erst jetzt darauf gestoßen. Aber das scheint keine Änderung zu produzieren, egal ob mit oder ohne l.


    Nun komme ich zur nächsten Hürde, ich bin unersättlich, aber das in einem neuen thread "cam-aufzeichnung"

  • Hallo Pit,


    das mit dem 48000l im zweiten Beispiel ist natürlich ein Fehler. Richtig ist 48000. Ich habe es schon korrigiert.


    Ja, der VLC ist gegenüber Fehler in der Kommandozeile sehr nachsichtig und ignoriert alles, was aus seiner Sicht Quatsch ist. Das hat Vor- aber auch Nachteile. Man wird auf seine Fehler nicht hingewiesen.


    MfG, kodela