DVD nach H264 konvertieren -> Video hat nun keinen Ton mehr

  • Hallo,


    ich habe ein Video welches von einer (älteren) Kamera auf DVD aufgenommen wurde. Der VLC-Player ist der einzige Player, mit dem ich es bisher ansehen konnte, ohne ständig hängende oder grüne Blöcke zu sehen. Nun habe ich versucht es wie im hier beschriebenen Kapitel 4 "Video von DVD konvertieren und speichern" in ein H264+mp3(mp4) Video zu konvertieren:
    https://www.vlc-forum.de/index…d-auf-festplatte-sichern/


    Die resultierende mp4-Datei enthält nun allerdings keinen Ton (Bild ist super). Kann mir jemand sagen ob/was ich falsch gemacht habe?


    Nachtrag: Ich glaube auch, dass das mp4-Video ein kleines bisschen schneller läuft als im Original hätte sein sollen.

  • Hallo hans_wurst,


    welche Einstellungen hast Du im Profil für den Audiostream, vermutlich MPEG Audio. Probiere auch einmal andere durch, zum Beispiel MP3 oder Vorbis.


    Probiere es auch mit der TS-Verkapselung (Video H.264 + MP3(TS)).


    MfG, kodela

  • Hallo kodela,


    Ausgehend von meinem DVD-Format (1,17GB) schreibe ich hier mal die Resultate der verschiedenen Konvertierungen. Das Häckchen bei "kein Disc-Menü" war immer gesetzt:


    Video H.264 + MP3(mp4)
    --> das war das Video ohne Ton


    Video VP80 +Vorbis(Webm)
    --> VLCplayer schließt sich sofort, 0 Byte große webm-Datei erscheint


    Video H.264 + MP3(TS)
    --> VLCplayer rödelt einige Zeit :) ; 80MB große ts-Datei erscheint; lässt sich mit VLC starten (nicht mit Win. MediaPlayer), zeigt jedoch recht bald Fragmente (nennt sich doch so?) die irngend wann "stehen bleiben"; Das ganze Video wird wesentlich früher abgebrochen als es ist.


    Video H.265 + MP3(mp4)
    --> player rödelt sehr lange; 132MB-Datei; schwarzes Video erscheint, aber diesmal mit Ton


    Theora + Vorbis (OGG)
    --> player rödelt sehr lange; 187MB-Datei; Video ca 4sec; Bild friert dann ein und Ton läuft weiter


    MPEG2 + MPGA (TS)
    --> player rödelt rellatiev kurz; 3MB-Datei; Bild und Ton für 16sec lang gut und dann Ende


    Dirac + MP3 (TS)
    --> sofortige Fehlerausgabe:
    "Streaming/Transkodierung fehlgeschlagen:
    Es scheint das Ihrer Libav/FFMPEG (libavcodec) Installation der/die folgende(n) Encoder fehlen:
    Dirac.
    Wenn Sie nicht wissen wie Sie dies beheben, fragen Sie nach Hilfe von Ihrer Distribution.
    Dies ist kein Fehler im VLC media player.
    Kontaktieren Sie nicht das VideoLAN-Projekt wegen dieses Problems."


    WMV + WMA (ASF):
    --> player rödelt kurze Zeit; 17MB-Datei; 16sec lang Video mit Blöcken; dann eingefrorenes Bild und gelegentliche Tonsequenzen


    DIV3 + MP3 (ASF):
    --> player rödelt kurze Zeit; 17MB-Datei; 16sec lang stark fragmentierte Bilder; dann ebenfalls eingefrorenes Bild und gelegentliche Tonsequenzen


    Ich hoffe die Infos helfen dir weiter für Tipps. Da das mein Hochzeitsvideo ist, habe ich natürlich großes Interesse :)

  • Hallo hans_wurst,


    meine Frage war: "welche Einstellungen hast Du im Profil für den Audiostream". Du solltest dafür nicht die ganze Profilliste durchprobieren, sondern in Deinem erst verwendeten Profil (Video H.264 + MP3(mp4)) die Einstellungen für Audio.


    MfG, kodela

  • Hallo hans_wurst,


    im rechten Bild ist das Register "Audiocodec" und das Unterregister "Encodierungsparameter" offen.


    Im Unterregister "Encodierungsparameter" sind vier Einstellungszeilen für

    • Codec (mit Auswahlliste)
    • Bitrate
    • Kanäle
    • Abtastrate (mit Auswahlliste)

    In der Zeile für die Codec-Einstellungen ist der MPEG Audio Codec voreingestellt. Wenn man mit der linken Maustaste auf diese Zeile klickt, klappt eine Auswahlliste auf, aus der man auch andere Codecs auswählen kann, zum Beispiel MP3. In dieser Zeile solltest Du die verschieden Codecs (außer Opus und Speex) durchprobieren.


    Die Bitrate und die Kanäle kannst Du lassen, wie sie sind, aber für die Abtastrate solltest Du den Wert 44200 Hz einstellen. Das geht auch wieder über eine aufklappbare Auswahlliste.


    Nach jeder Einstellungsänderung den Dialog über die Schaltfläche "Speichern" verlassen und den VLC neu starten. Erst dann die Konvertierung vornehmen.


    MfG, kodela

  • Hallo Kodela,


    das hier sind die Ergebnisse der verschiedenen Ton-Formate.
    In der Hoffnung, dass es eine Hilfe sein könnte, habe ich nochmal einen screenshot von den Einstellungen für das Medium angehängt:
    http://www.bilder-upload.eu/upload/6da4f0-1457474715.png
    Testhalber habe ich die Audiospur mal von -1 auf 0 geändert (Griff nach dem Strohalm, ohne zu wissen was passiert). Bei "Encodierungsparameter=MP3" bekomme ich aber wie jedes mal ein Video ohne Ton.
    Für die anderen Tests habe ich es wieder zurück auf -1 geändert.


    mit MP3, A53/AC-3, Vorbis, Flac, WAV, WMA2 und MPEG4 Audio (AAC): Video ohne Ton


    Bei MPEG4 Audio (AAC): zuzüglich gibt es diese Fehlermeldung: "Streaming/Transkodierung fehlgeschlagen:
    VLC konnte den mp4a Audio Encoder nicht öffnen.
    "


    Um sicher zu stellen, dass mein Tonproblem nicht am PC liegt: Starte ich das Original-Video, ist der Ton wieder zu hören.

  • Hallo hans_wurst,


    öffne eine der VOB-Dateien mit dem VLC, spiele sie an und öffne dann über Strg+J die Codec-Informationen. Was wird hier für den Audiostream angezeigt?


    Wenn es mit dem Konvertieren und Speichern nicht klappt, dann gibt es doch noch andere Wege, zum Beispiel die VOB-Dateien packen oder Handbrake verwenden.


    MfG, kodela

  • VOB-Packer:
    Ich wähle meine Datei VTS_01_1.VOB (623MB) aus und klicke auf öffnen. Erhalten jedoch die Info "Es wurde keine gültige Quelldatei eingegeben. Sie können erneut wählen."
    Der packer kann anscheinend nichts mit meiner kaputten (?) Datein anfangen.


    Mit Handbreake lief nun alles gut. Herzlichen Dank dafür, dass ihr mich hier mit so viel Ausdauer unterstützt habt. Ich bin echt froh darüber :)