Bild-Störungen in unregelmäßigen Abständen

  • Hi, habe mich hier extra wegen meines Problems registriert :)


    Es geht um seltsame ca 5-10 Sek. Bild-Störungen in unregelmäßigen, 10-20 Min. Abständen (Bild 1)


    Es liegt nicht an den Filmen (avi oder mkv, 720p), weil wenn ich die betroffene Szene erneut betrachte (nachdem die Wiedergabe wieder OK ist), ist das Bild OK (Bild 2)


    Ich vermute, die Störungen dauern immer bis zum nächsten Keyframe.
    Bei WMP oder PotPlayer (die einzige Player-Alternative für mich) habe keine Störungen...


    Habe Laptop Dell mit Win7 64-Bit.
    Getestet habe ich mehrere VLC-Versionen: 32- und 64-Bit 2.2.2, 2.2.1, 2.1.5 - bei allen das gleiche...


    Danke im Voraus für Vorschläge! ;)

  • Vielen Dank kodela für die Antwort :)


    Von der Laptop-Festplatte.


    Die Störungen habe am TV (per HDMI), aber auch am Laptop selbst. Im Vollbild, aber auch verkleinert...
    Gestern habe den Film mit PotPlayer geschaut - keine einzige Störung. Es liegt also eindeutig am VLC...


    Meine Vermutung, die Störungen dauern immer bis zum nächsten Keyframe, stimmt - habe die Keyframes-Zeiten im VirtualDub überprüft. Darum die Dauer der Störungen ist unterschiedlich - je nach Zeitabstand der Keyframes.


    Im Hintergrund laufen keine, von mir gestarteten, Programme.


    Viele Grüße
    augustus

  • Version 2.0.8 -> die "Aussetzer" haben abgenommen, aber das "Ruckeln" stark zugenommen... :(
    Version 1.1.11 -> wie oben...


    Die beste Version ist für mich 2.2.1 x64 Portable (die 2.2.2 hat grünen Strich unten ;) ) und bei der bleibe ich im Moment.


    Wahrscheinlich liegt es am ATI/AMD...
    Hatte paar Wochen Win 10 mit neuem AMD und da war ALLES perfekt.
    Jetzt habe wieder Win 7 mit ATI vom 2009 (habe ATI Mobility Radeon HD 5650).
    Bis ich mich wieder für Win 10 entscheide, benutze ich den PotPlayer (ist wirklich sehr, sehr gut).


    Viele Grüße
    augustus

  • Hallo Augustus,


    das Phänomen ist bekannt. Unter mpeg TS tritt dieses Phänomen häufiger auf. Deswegen möchten wir jetzt auch in unserem Krankenhauskanal alle Dateien umwandeln
    von mpeg TS auf PS. (Programmstream). Die "i" Bilder sind beim TS Stream anders, als beim Programmstream. Wandle einfach Deine Videos in einen mpeg2 PS
    dann verschwinden auch alle Probleme. Habe dazu heute im Forum eine Anfrage gestellt, wer ein einfaches Programm kennt, mit dem man TS auf PS
    ohne erneute Encodierung umwandeln kann. Warte noch ab. Vielleicht hat Kodela einen Tipp.

  • Richtig kodela - es handelt sich um XviD / MKV / 720p / 1080p.
    Vom Umwandeln kann keine Rede sein.
    Ich habe gehofft auf ein Hinweis, in den Einstellungen etwas an- bzw. abhacken, aber ohne Quali-Verlust...


    Gruss
    augustus

  • Hallo augustus,


    Du könntest einmal versuchen, in der Rubrik Anzeige der einfachen Videoeinstellungen für Ausgabe nach der Option Automatisch die ersten fünf Ausgabemodule von Direct3D-Videoausgabe bis Windows GDI-Videoausgabe durchzuprobieren. Nach jeder Einstellungsänderung den Dialog über die Schaltfläche Speichern verlassen und den VLC neu starten.


    MfG, kodela

  • Hallo,


    meine Probleme mit den "Video-Aussetzer" habe leider auch in der neuesten, installierten Version 2.2.4 x32 :(
    Die Störungen habe in unregelmässigen Abständen und sie dauern immer zwischen 2 Keyframes. Die Dauer der Störungen ist unterschiedlich - je nach Zeitabstand der Keyframes.
    Habe AMD/ATI Mobility Radeon HD 5650.


    Klavierspieler schreibt hier von "Blitzfehler in unregelmässigen Abständen" / "weißes Aufblitzen von Videos":
    Anleitung: weißes Aufblitzen von Videos vermeiden


    Vielleicht können seine Hinweise auch mir helfen?
    Sind die Einstellungen ohne Quali-Verlust?


    1. Einstellungen: Videoausgabe "Automatisch" -> "Windows GDI Vidoausgabe"
    2. Einstellungen: Video / Fensterdekorationen -> Haken raus
    3. Eingang / Codecs (Erweitert): Datei Cachewert + Cachewert für Live + Disk Cachewert + Cachewert für das Netzwerk -> auf 3000 einstellen.


    Und noch etwas... Kann man den grünen Strich unten (seit Version 2.2.2) beseitigen?


    Viele Grüße
    augustus

  • Hallo augustus,


    Du hast auf meine letzte Antwort zu Deinem Problem vom 22. Mai dieses Jahres bisher nicht reagiert. Bevor ich nun auf Deine neue Frage eingehe, möchte ich gerne wissen, ob Du, wie von mir empfohlen, die verschiedenen Ausgabemodule durchprobiert hast und wenn ja, mit welchem Erfolg.


    MfG, kodela

  • Hallo kodela,


    tut mir Leid, habe ich leider nicht ausprobiert, bin ich auf den PotPlayer umgestiegen.
    Erst gestern habe ich die neueste Version von VLC entdeckt und beschlossen noch einmal zu versuchen, mit ihm klarzukommen...
    Dazu bin ich zufällig auf die geprüften Hinweise von Klavierspieler gestossen...
    Die Frage ist, ob die Störungen ähnlich und die Einstellungen ohne Quali-Verlust sind.


    Ich probiere seine Hinweise heute aus - zuerst die 1. "Windows GDI Vidoausgabe", dann die 2+3 und falls ohne Erfolg alle 3.


    Wollte einfach wildes Versuchen vermeiden - es gibt zu viele ungeprüften Ratschläge, dazu noch mit Quali-Verlust...


    Sind die Einstellungen von Klavierspieler ohne Quali-Verlust?


    Viele Grüße
    augustus

  • Sind die Einstellungen von Klavierspieler ohne Quali-Verlust?

    Hallo augustus,


    Die Anleitung von Klavierspieler bezüglich dem "weißen Aufblitzen von Videos" hat mit Deinem Problem überhaupt nichts zu tun. Er hat aber in diesem Thema empfohlen, TS-Dateien zu PS-Dateien zu konvertieren. Das sollte Dich aber ebenfalls nicht berühren, da Du doch geschrieben hast, bei Deinen Filmen handle es sich um AVI- oder MKV-Filme, also keine TS-Videos.


    Probiere also einmal alle Ausgabemodule aus, dann sehen wir weiter.


    MfG, kodela

  • Und noch ein sehr wichtiger Hinweis:
    Bei Einstellungen - Ausgabe darf auf keinen Fall Videoausgabe automatisch angewählt werden. Hier ist unbedingt die Einstellung "Windows GDI Vidoausgabe" anzuwählen von Microsoft. Diese Ausgabeform wird dann erzwungen und es läuft wie geschmiert.
    Wir haben den beschriebenen Fehler mehrmals bei uns im Krankenhauskanal simulieren können. Die Voreinstellung "Videoausgabe Automatisch" nehmen einige GTX oder AMD Radeon Grafikkarten zwar ohne die Auswirkungen zu hinterfragen an, aber es werden dann eben jene beschriebene "Blitzfehler in unregelmässigen Abständen" produziert. Also mit diesen übermittelten Einstellungen klappt es einwandfrei ! :thumbup:

    OK, ich hoffe eigentlich nur auf die Einstellung "Windows GDI Vidoausgabe" - mal sehen... ;)

  • Hallo Augustus,


    ich weiß, was Klavierspieler geschrieben hat. Du musst das aber im richtigen Kontext sehen. Er hat sein Thema wie folgt begonnen:


    Anleitung weißes "Blitzen" zwischen den Videos vermeiden


    Nun möchten wir nur nicht immer Fragen stellen, sondern auch aktiv unsere Erfahrungswerte mit unserem kleinen Krankenhauskanal den wir mit dem VLC Player abwickeln zur Verfügung stellen.


    Sicherlich wird sich der ein oder andere Teilnehmer in diesem Forum fragen, welche Vermeidungsstrategien durchgeführt werden müssen um ein "aufblitzendes Weiß" zwischen den Videos zu vermeiden.

    MfG, kodela

  • Hi kodela,


    das "zwischen" habe ich auch gesehen, aber gehofft auf Ähnlichkeit des Problems...


    Also... Wollte mit der Einstellung "Windows GDI Vidoausgabe" meine Tests beginnen, aber keine Ahnung warum, habe zuerst:


    Fensterdekorationen -> Haken raus
    und
    Cachewerte -> alle 4 auf 3000


    und 720p AVI gestartet - und hatte KEINE EINZIGE STÖRUNG !!! 8o:thumbsup:

    Nicht zu fassen, endlich! Ich hoffe, es bleibt so... :)


    Diese 2 (eigentlich 5) Einstellungen haben mit Quali nichts zu tun, oder?


    Kann man den grünen Strich am unteren Bildrand beseitigen? Hast Du den Strich auch?


    Viele Grüße
    augustus

  • Hallo augustus,


    also mit der Fensterdekoration hat Dein Problem nichts zu tun, das ist Geschmackssache. Wenn das System selbst in Ordnung ist, dann sollte allenfalls bei ungünstigen Empfangsbedingungen eine Erhöhung des Cachewertes für das Netzwerk erforderlich sein.


    Du hast mit Deinen Einstellungsänderungen einen Teilerfolg erzielt. Trotzdem rate ich Dir dringend von solch unkontrollierten Änderungen ab. Einfach auf gut Glück mehrere Änderungen vornehmen ist der sicherste Weg, sich seine Einstellungen total zu versauen. Du veränderst einfach so vier Werte. Was hättest Du getan, wenn das nichts gebracht hätte? Selbst wenn Du jetzt davon ausgehen kannst, dass eine dieser vier Änderung Dir geholfen hat, sind drei andere unnötigerweise mit geändert. Das mag bei den Cachewerten kein großes Unglück sein, aber ich kann mir gut vorstellen, dass sich solche unkontrollierten Änderungen, zwar nicht immer sofort, in einer anderen Situation zum Problem werden können.


    Ich muss ständig für Testzwecke an den Einstellungen "herumschrauben". Dabei mache ich mir vor jeder Änderung eine Sicherheitskopie der Konfigurationsdatei, ändere dann nur einen Wert und prüfe die Auswirkung nach einem Neustart. Je nach dem kann ich dann die Änderung zurück nehmen oder an anderer Stelle noch etwas ändern. Letztlich weiß ich dann, ob und welche Änderung geholfen hat, so dass sie übernommen werden kann oder ob alle Änderungen verworfen werden können, indem ich auf meine gesicherte Konfigurationsdatei wieder zurück gehe.


    Ich habe den Verdacht, dass die von Dir beschriebenen Änderungen der Cache-Einstellungen nicht Deine einzigen Änderungen waren. Ich empfehle Dir deshalb dringend alle Änderungen wieder zurück zu nehmen, so wie es im Thema Alle Einstellungen zurücksetzen beschrieben ist.


    Danach versuchst Du, den Datei-Catchewert schrittweise von 300 bis 3000 zu erhöhen (600, 1000, 1500 usw.). Da die Störungen ja nur bei der Wiedergabe von Dateien auftreten, sollten die anderen Cachewerte keinen Einfluss haben. Falls aber die Störungen auch bei einem Datei-Cachewert von 3000 noch auftreten, dann setzt Du diesen wider zurück und versuchst es mit dem Cachewert für Lifeaufnahmen.


    Erst wenn Du auf diese Art und Weise keine Aussetzer mehr hast, kannst Du an das Problem mit dem grünen Strich am unteren Rand gehen. Dafür probierst Du die Ausgabemudule durch, wie ich es Dir geraten habe. Dieser grüne Strich darf nicht sein.


    Hast Du schon an den Grafikkartentreiber gedacht? Ich bin mir ziemlich sicher, dass mit Deinem System etwas nicht in Ordnung ist.


    MfG, kodela

  • Hi kodela,


    meine einzige Änderung davor war "Lautstärke immer 100%".
    Was hätte ich getan, wenn die Änderungen nichts gebracht hätten? Einfach zurück, ist doch klar...
    Klavierspieler hat in senem Fall die Änderungen getestet, also es waren keine unkontrollierten Änderungen.


    Meine Störungen traten in unregelmäßigen, 10-20 Min. Abständen. Du willst, dass ich jeden Cachewert teste?! 4 mal 6 Schritte?! Das macht ca 24 Filme! Weiss Du, wie lange das dauert?


    Und dann die 5 Ausgangsmodi's - da sah ich Gefahr, etwas zu verstellen...


    Ich weiss noch nicht, ob die Störungen endgültig weg sind... Nach einigen Filmabenden weiss ich mehr :)


    Weisst Du, wie man den grünen Strich wegmacht oder nicht? Soll ich dafür die 5 Ausgangsmodi's testen?


    Der Strich ist ab der Version 2.2.2 :(


    Viele Grüße
    augustus

  • Weisst Du, wie man den grünen Strich wegmacht oder nicht? Soll ich dafür die 5 Ausgangsmodi's testen?
    Der Strich ist ab der Version 2.2.2

    Hallo augustus,


    Du musst überhaupt nichts testen. Ich habe Dir etwas empfohlen und was Du davon machst, ist ganz Deine Sache.


    Jetzt empfehle ich Dir noch, die Version 2.1.5 / 32 Bit zu verwenden und wenn es damit funktioniert bei dieser Version zu bleiben. Es gibt für Dich keinen Grund immer die neueste Version zu verwenden.


    MfG, kodela