Einige Streams aus MediathekView lassen sich nicht speichern

  • Guten Tag,


    ich nutze gerne Mediathekview, um Beiträge aus der WDR-Mediathek zu sichern. In der Filmliste gibt es zwei Button, einen zum direkten Abspielen in VLC, einen zum Download. Direktes Abspielen ist problemlos möglich, und ich könnte den Stream auch direkt aufnehmen (roter Kreis im VLC). Praktischer fände ich den Download, dann kann ich mehrere Sendungen "in einem Rutsch" sichern. Beim Klick auf den Download-Button startet der VLC im CMD-Fenster und gibt bei einigen Streams diese Fehlermeldung aus:

    Code
    [0062d1dc] dummy interface: using the dummy interface module...
    [0065c59c] httplive stream: HTTP Live Streaming (adaptiv.wdr.de/i/medp/ww/fsk0/1
    20/1202096/,1202096_13901442,1202096_13901444,1202096_13901441,1202096_13901445,
    1202096_13901443,.mp4.csmil/index_2_av.m3u8)
    [00672404] ts demux: MPEG-4 descriptor not found for pid 0x101 type 0xf
    [025a2494] packetizer_mpeg4audio decoder: AAC channels: 2 samplerate: 48000
    [00672404] ts demux error: libdvbpsi error (PSI decoder): TS duplicate (received 0, expected 1) for PID 4095

    Mediathekview meldet: "Download fehlerhaft" und es wird keine Videodatei angelegt.


    Herausfinden konnte ich schon, dass das nur bei Dateien mit der Endung .asf passiert - im Beispiel wird als Dateiname "Lokalzeit Münsterland-Lokalzeit Münsterland-index_2_av.m3u8.asf" angegeben. Bei Endungen mit .flv gibt es keine Probleme. Ich vermute, der WDR hat das Stream-Format umgestellt.


    Über Google habe ich die Tipps gefunden, eine ältere Version des VLC zu installieren - ich habe VLC 2.0.6 ausprobiert, die im Thread genannt war - und auch die experimentelle VLC 3 beta getestet, leider ohne Erfolg.


    Ich nutze WIN 7, 64 bit, Mediathekview 12 (32 bit) und Java 1.8, sowie VLC 2.2.4 (32 bit). Vielleicht liegt es an den Codec-Einstellungen? Über einen Tipp, in welche Richtung ich weiter forschen könnte, würde ich mich freuen.


    Viele Grüße,


    Stefan

  • Hallo Stefan,


    ja, bestimmte Dateiformate führen beim VLC mit den Einstellungen von MedithekView zu Fehlern. Trotzdem gibt es mindestens drei Möglichkeiten, wie man solche Streams von MediathekView speichern kann:

    • Die erste, schwierigste und umständlichste wäre, das Set für das Speichern mit dem VLC zu bearbeiten.
    • Die zweite, den Video-URL aus MedithekView zu kopieren und damit das Video mit dem VLC über die Menüoption Medien - Konvertieren/Speichern... zu speichern.
    • Die dritte und einfachste erfordert lediglich eine einmalige Umstellung der Reihenfolge für die von MediathekView zum Speichern verwendeten Hilfsprogramme. Dazu über die Menüoption Datei - Einstellungen in der Sektion Aufzeichnen und Abspielen Untersektion Set bearbeiten die Option alle Einstellungen anzeigen aktivieren und im Register Hilfsprogramme über die beiden Pfeilsymbole im rechten Bereich mit den Set-Definitionen das Set flvstreamer (rtmp <#>) an die erste Position der Auswahl bringen.

    MfG, kodela

  • Hallo kodela,


    vielen Dank für die ausführliche Antwort! Ich habe natürlich zuerst die dritte Variante ausprobiert. Leider stand in meinem Set der flvstreamer schon an der ersten Stelle. Da er sich offensichtlich für Streams mit *.asf nicht "zuständig" fühlt und doch immer der VLC gestartet wird, habe ich versucht, ihn im Set zu kopieren und *.asf "zuzuordnen", sie Screenshot von den Einstellungen.

    Das hat leider auch nicht funktioniert. Ich sehe aber ein, dass das wohl mehr ein Problem von Mediathekview und nicht vom VLC ist. Ich probiere weiter ;)


    Viele Grüße, Stefan

  • Hallo Stefan,


    bei mir funktioniert der Download bei allen derzeit sieben "Lokalzeit Münsterland" m3u8-Videos. asf- und flv-Videos habe ich in meiner MediathekView-Liste nicht. Alle m3u8-Videos dieser Sendereihe stehen auch im mp4-Format zur Verfügung. In diesem Format lassen sie sich auch über den VLC problemlos downloaden. Die Namenserweiterung ist bei mir in allen Fällen .mp4, auch wenn es laut den Einstellungen für das jeweilige Set anders sein müsste (.flv, .ts).



    Einziger Unterschied zwischen Deiner und meiner Einstellung, soweit ich das in Deinem Screenshot sehen kann: Du hast den flvstreamer (rtmp <#> ) ohne Präfix, bei mir hat er das Präfix "rtmp".



    MfG, kodela

  • Hallo kodela,


    danke, dass du dir das so genau angeschaut hast. In der Filmliste steht bei mir auch nichts von *.asf, das hatte ich missverständlich ausgedrückt, dort enden die Videos, um die es mir geht, mit ...,mp4.csmil/index_2_av.m3u8. Aber wenn ich diese Datei downloaden will, wird mir im Dialogfeld ein Dateiname mit *.asf angeboten, siehe Screenshot:



    Du schreibst:
    Alle m3u8-Videos dieser Sendereihe stehen auch im mp4-Format zur Verfügung


    Das kann ich nicht so ganz nachvollziehen, in der Filmliste sehe ich nur einzelne, ältere Beiträge der "Lokalzeit", die auf *.mp4 enden.


    Mein Problem scheint zu sein, dass Mediathekview bei mir zum Download immer auf den VLC zurückgreift und eben nicht auf den flvstreamer, der das vielleicht besser könnte. Da werde ich mich wohl mit der Definition der Sets in Mediathekview intensiver beschäftigen müssen :-)


    Wahrscheinlich sehen unsere Sets zum Speichern jetzt gleich aus (Screenshot) und die Dateiendung *.asf wird angehängt, weil das beim VLC so im Set steht.


    Freundliche Grüße,


    Stefan

  • Hallo Stefan

    Du schreibst:
    Alle m3u8-Videos dieser Sendereihe stehen auch im mp4-Format zur Verfügung

    Du solltest Dir die Sendungen von der ARD zeigen lassen. Hier ein Bild, wie das bei mir aussieht:

    Ab der blauen Markierung sieht man die Sendungen vom WDR und darüber die von der ARD. Jeder Eintrag vom WDR hat ein Gegenstück bei der ARD. Dort gibt es aber noch einige weitere Sendungen.


    Und hier noch ein Bild von den Einstellungen bei mir:


    Wenn MediathekView bei Dir immer auf den VLC zurück greift, obwohl dieser in der Auflistung nicht an erster Stelle steht, könnte es sein, dass die beiden anderen Programme nicht zur Verfügung stehen. Überprüfe das einmal.
    MfG, kodela

  • Hallo kodela,


    herzlichen Dank, es hat geklappt!


    Auf den Trick, die WDR-Beiträge unter ARD zu suchen, bin ich noch nicht gekommen, da gibt es die WDR-Sendungen, die ich gesucht habe, tatsächlich als *.mp4. Und die ließen sich problemlos downloaden.


    Auf deinem Screenshot habe ich gesehen, dass mir das Set zu ffmpeg komplett fehlt! Keine Ahnung, warum, ich hatte während der Fehlersuche die 11er-Version der Mediathekview gelöscht und die 12er-Version mit Standardsets neu installiert. Also habe ich jetzt den Eintrag zu ffmpeg mit dem Schalter -i %f -c copy -bsf:a aac_adtstoasc "**" ergänzt - und schon funktioniert es auch auf diesem Weg. :)


    Freundliche Grüße,


    Stefan