iP Kamera an VLC klappt, Videoaufnahme nicht

  • W10 - VLC 2.2.2

    Wenn ich vermeintlich Aufnahmen von der iP Kamera speichere,

    bekomme ich beim Abspielversuch die Fehlermeldung

    "Der Datenstrom enthält keine Daten"

    Es werden Dateien *.mkv und .odd geschrieben, sieht eher nicht wie eine Videoaufnahme aus :(


    Werkzeug - Einstellungen - Video - Ausgabe - ich habe alle Möglichkeiten probiert, leider sehe ich die Filme nicht.

    Was mach ich falsch?

  • Hallo OttoZ,


    hast du im Menü / Werkzeuge / Einstellungen / Eingang-Codecs einen Dateipfad für das Aufnahmeverzeichnis angelegt?

    Nach dem Eintragen des Aufnahmeverzeichnisses die Änderungen im VLC-Player speichern und einen Neustart ausführen.


    Siehe Bildschirmausdruck "Einstellungen-Eingang-Codecs.png".


    Eine Dateiendung *.odd kenne ich nicht im Zusammenhang mit dem VLC-Player.

    *.mkv und *.ogg sind zwei verschiedene Videocontainerformate, die der VLC-Player abspielen kann.


    Für die einfache Aufnahme über die rote Aufnahmeschaltfläche wird das originale Dateiformat behalten.

    Der Dateinahme einer Aufnahme mit dem VLC-Player lautet in etwa "vlc-record-2017-12-25-14h29m51s-...".


    MfG

    Thomas

  • thweiss ... danke für den Tipp ... die Einstellung hatte ich noch nicht gefunden.

    Schnappschüsse gelingen, für Videos werden leere Dateiordner angelegt.

    z.B.

  • Hallo OttoZ,


    1) setze mal bitte die Einstellungen des VLC-Players zurück?

    Menü / Werkzeuge / Einstellungen / in den Oberflächeneinstellungen ganz unten die Schaltfläche [Einstellungen zurücksetzen] anklicken.

    Danach einen Neustart des VLC-Players durchführen.


    2) Welche Codec-Informationen (Tastenkombination [Strg]+[j]) zeigt der VLC-Player bei der Videowiedergabe von der IP-Cam an?


    3) Im Meldungsfenster (Tastenkombination [Strg]+[M]) des VLC-Players kann man die Ausführlichkeit auf die Stufe 2 ändern und danach eine Aufnahme der IP-Cam starten. Die Informationen im Meldungsfenster können vielleicht weitere Hinweise geben.


    4) Kannst du in der IP-Cam Änderungen der Streaming-Parameter (Codec, Conatinerformat, Streaming-Protokoll...) vornehmen?


    MfG

    Thomas

  • Danke Thomas, für die Unterstützung! Ich komme weiter, das resett habe ich durchgeführt, Aufnahmen einer miesen, aber teuren Aldikamera konnte ich aufzeichnen und wiedergeben.

    Bei der chinesischen klappt es noch nicht, sie läßt sich aber konfigurieren - wozu mir leider die Kenntnis fehlt.

    Kannst Du mir helfen?


  • Hallo OttoZ,


    schön, dass zumindest mit der Aldi-Kamera die Aufzeichnung und Wiedergabe mit dem VLC-Player funktioniert.


    Für die andere Kamera würde ich im "Video Format" mit "H264_Baseline" beginnen, wegen geringerer Datenraten.

    Link: https://de.wikipedia.org/wiki/H.264#Level


    Die Video Größe ("Video Size") würde ich erst einmal auf 1280 × 720 veringern.

    Unter "Stream Mode" kann man bestimmt zwischen "vbr" (variable Datenrate) und "cbr" (konstante Datenrate) auswählen.

    Hier würde ich zuerst bei konstanter Datenrate ("Fixed Quality") bleiben.

    Der unter "VBR" eingetragene Wert sollte bei konstanter Datenrate nicht verwendet werden.


    Für die Tonwiedergabe würde ich ebenso ein anderes "Audio Format" als "G711A" verwenden.

    Hier ist die Frage, was die Kamera an Audio Formaten zur Auswahl anbietet.

    Der VLC-Player unterstützt folgende Formate: https://wiki.videolan.org/VLC_Features_Formats/#Audio_Codecs.


    Für das Streaming würde ich "http" gegenüber "udp" und "rtp" bevorzugen.

    Link: https://www.videolan.org/streaming-features.html

    Diese Einstellungen kann man möglicherweise unter "Network Parameter / Active Connection" oder "Center Platform" in der Kamera einstellen.


    MfG

    Thomas

  • ... danke, ich werde die Tipps mal durchprobieren.


    Etwas rätselhaft ist mir, warum spielt VLC die Videos problemlos ab aber speichert sie nicht?

    Laienhaft denke ich mal, die Codes müssen vorhanden sein.


    edit: die Gerätesoftware NVClient zeichnet Videos im Format *.asf auf, diese spielt VLC problemlos ab.

  • Hallo OttoZ,


    du könntest in den Einstellungen des VLC-Players überprüfen, ob "Bevorzuge native Streamaufnahme" aktiviert ist.

    Im Menü / Werkzeuge / Einstellungen - Alle / Eingang-Codecs in der rechten Spalte nach unten scrollen und "Bevorzuge native Streamaufnahme" prüfen.

    Siehe Bildschirmausdruck "Einstellung-native-Streamaufnahme.png".


    Die Änderung jeweils speichern und anschließend einen Neustart des VLC-Players ausführen.


    MfG

    Thomas