VLC ignoriert gegebene Bildschirmkoordinaten

  • Hallo,


    ich möchte gern den vlc-Player dazu bringen, via Konsolen-Befehl ein Videoclip auf einem zweiten Monitor in Vollbild auszugeben, ohne Steuerelemente oder Mauszeiger oder sonst etwas. Einfach nur den Film. Dafür habe ich mir folgendes zusammengeschnitzt:


    cvlc -f --no-overlay --no-video-title-show --video-x 100 --video-y 100 sample.mp4


    VLC ignoriert hartnäckig --video-x und --video-y. Was mache ich falsch?


    (Mein Betriebssystem ist Ubuntu 16.04, die Playerversion 2.2.2 Weatherwax)

  • Danke!


    Hier zuhause hab ich grad keinen zweiten Bildschirm, deswegen habe ich das Vollbid weggelassen. Auch mit Gleichheitszeichen befindet sich die Ausgabe des Videos in der Mitte des Bildschirms und bewegt sich auch mit veränderten Werten dort nicht weg.


    Auch vereinfacht auf cvlc --video-x=1000 --video-y=100 sample.mp4 ergibt sich keine Veränderung.

  • Hallo Zerga,

    anbei füge ich ein Beispielscript für die 64-Bit Version 3.0.1 des VLC-Players, mit dem sich die Bildposition (linke obere Ecke) festlegen lässt.

    Für die Wiedergabe auf dem zweiten Monitor müssen die Bilpunkte des ersten Monitor berücksichtigt werden.


    Wiedergabe "ZDF HD" Livestream per Commandozeilenscript für 64-Bit Version des VLC-Players an definierter Bildposition:

    Code
    start "" "C:\Program Files\VideoLAN\VLC\vlc.exe" --qt-start-minimized --no-video-title-show --no-embedded-video --no-video-deco --video-x=200 --video-y=200 http://zdf1314-lh.akamaihd.net/i/de14_v1@392878/master.m3u8

    Die Parameter --no-embedded-video --qt-start-minimized und --no-video-deco sollten im Script enthalten sein.


    MfG

    Thomas