Mehrere Videos hintereinander mit verschiedener Tonspur abspielen

  • Hallo,


    ich versuche, mehrere Videos hintereinander mit VLC abzuspielen.


    Mit vlc video1.avi video2.avi in der Kommandozeile geht es.

    Jedem Video möchte ich eine bestimmte Tonspur geben.


    Für ein Video bekomme ich es hin

    vlc video1.avi --input-slave=audio1.wav --audio-track 1


    Für zwei Videos funktioniert der Spaß nicht..


    vlc video1.avi --input-slave=audio1.wav --audio-track 1
    video2.avi --input-slave=audio2.wav --audio-track 1


    Wo liegt mein Fehler? Oder kann VLC das nicht, was ich möchte?


    Ich bin für jeden Hinweis dankbar :)


    Schöne Grüße:)

  • Hallo Laale18,


    es wäre möglich, dass man im VLC-Script nur jeweils für ein AV-Medium spezielle Parameter festlegen kann.

    Ich habe hierfür noch keine Tests durchgeführt.


    In der Kommandozeilenhilfe findet man die jeweiligen Parameter und Hinweise zur Verwendung für den VLC-Player.

    - https://wiki.videolan.org/VLC_command-line_help/


    In deinem konkreten Beispiel solltest du das Gleichheitszeichen für den jeweiligen Audio-Track des Titels im Parameter ergänzen (--audio-track=1). Möglicherweise besitz die Tonspur eine ID, so dass man als Parameter --audio-track-id=nnn auch ausprobieren könnte.


    Mit dem Parameter --input-slave=n nimmt man eine weiteres Quellsignal zur Wiedergabe eines Medium hinzu.

    Dies wäre zum Beipeil sinnvoll, wenn man ein Video abspielen will, dass keine Tonspur enthält und Ton gewünscht ist.


    Alternativ könnte man z.B. eine *.m3u Wiedergabeliste testen.

    #EXTM3U

    #EXTINF:-1,3sat

    #EXTVLCOPT:audio-track=n

    c:/video/video1.avi


    - https://www.thaivisa.com/forum…m-as-default-in-m3u-file/

    Die Idee mit der Option habe ich aus dem obigen Link entnommen und noch nicht ausprobiert.


    Hoffe, die Informationen helfen weiter.


    MfG

    Thomas

  • Hallo thweiss,


    mittlerweile habe ich eine Lösung gefunden.

    Bei meinen Videos handelt es sich um Videos ohne Ton.


    vlc video1.avi :input-slave=audio1.wav video2.avi :input-slave=audio2.wav

    wichtig war hier ein : statt -- , da der Doppelpunkt nur für das direkte Objekt gilt, nicht für alle wie --.


    Bei Videos mit Tonspur hat es übrigens keinen Unterschied gemacht, ob ich audiotrack 1 oder audiotrack=1 schreibe.


    Danke dir nochmal :)


    Grüße


    Laale