MP4 Wiedergabe geht nicht

  • Hallo, ich habe mir eine Canon Powershot SX740HS gekauft und liebe es, Fotos und Videos von Modellbahnen zu machen. Das Herunterladen klappt einwandfrei, auch die Wiedergabe von Fotos, jedoch nicht die Wiedergabe von Videos (MP4). Canon sieht das Problem beim VLC Player. Ich habe die neueste VLC-Version downloaded und arbeite mit Windos 7 (64 bit). Ich weiß nicht mehr, wo ich noch suchen könnte. Wer hat weitere Tipps?

  • Hallo Hamster,


    ich habe deinen Beitrag in dieses Unterforum verschoben, da es hier besser reinpasst.


    Verwendest du die 64-Bit Version des VLC-Players für die MP4-Wiedergabe von der Canon Powershot SX740HS?


    - 64-Bit: "C:\Program Files\VideoLAN\VLC\vlc.exe"

    - 32-Bit: "C:\Program Files (x86)\VideoLAN\VLC\vlc.exe"


    MfG

    Thomas

  • Hamster

    Ich gehe davon aus dass du die Videos auf der Kamera selbst abspielen kannst, oder gibt es da auch Probleme? Zeigt dir VLC eine Fehlermeldung oder ähnliches an?


    Schau dir auch mal in der Kamera an, welchen Video- und Audio-Codec für die Videos benutzt wird und überprüfe diese Angaben bitte anschließend in den Medieninformationen der Dateien mittels VLC (ein Bild dieser Daten wäre evt. nicht schlecht).


    Laut Datenblatt sollten ja folgende Codes verwendet werden:

    Code
    1. MP4
    2. Movie: MPEG-4 AVC / H.264
    3. Audio: MPEG-4 AAC-LC (Stereo)


    Es wäre evt. auch sehr hilfreich wenn du ein kurzes Video erstellen könntest, was du dann hier verlinkst.

  • Hallo thweiss,

    ich gehe davon aus, daß es mit 64-Bit: "C:\Program Files\VideoLAN\VLC\vlc.exe" wohl automatisch so gegeben ist. Etwas anderes geht wohl nicht - oder?


    Hallo Rocky4:

    1. Richtig - ich kann die Videos auf der Kamera abspielen - das funktioniert.

    Beim Versuch, Videos abzuspielen, wurde anfangs eine Fehlermeldung angezeigt - jetzt nicht mehr. Vielleicht, weil ich danach die Version 3.0.6 downloaded habe.

    2. Deine Codec-Daten habe ich versucht zu verifizieren. Weder im Handbuch für die Canon Powershot 740 etc. (aus Internet runtergeladen) habe ich etwas über Codes' gefunden noch auf der Canon selbst. In dem Zusammenhang ist mir jedoch aufgefallen, daß beim Antippen des Videos, dann bei Werkzeuge und dann bei Codes nichts "drin" ist, also blank (Allgemein/Metadaten//Codes/Statistiken) und das man an der Stelle auch nichts reinschreiben kann. Meine Vermutung war, daß hier die Codes reinzuschreiben wären - was also gar nicht ginge.

    Hat das den Fall eingeengt?

    Bis jetzt mal Danke für die Mühe.

  • Hallo Hamster,


    Im Internet findet man weiterführende Informationen zum verwendeten Videocodec der Kamera.

    - https://www.canon.de/cameras/p…-sx740-hs/specifications/


    Beim Thema 32-Bit / 64-Bit Version gab es in der Vergangenheit sehr oft Unterschiede.

    In den 2.X-Versionen war die 32-Bit Version fehlerfreier als die 64-Bit Version.


    Mit der Version 3.X wird die 64-Bit Version des VLC-Players von den Entwicklern empfohlen.


    Hier könnte man also mal eine andere VLC-Version ausprobieren.


    Möglicherweise liegt auch ein hardwareproblem im PC vor.

    Dazu müsste man prüfen, ob alle Treiber (Grafik, Chipsatz, Ton...) aktuell sind.


    MfG

    Thomas

  • Also wenn VLC den Codec nicht anzeigt kann er ihn wohl nicht ermitteln, weshalb dann auch klar ist wieso er die Videos dann nicht abspielen kann.


    Also du solltest sicherlich irgendwo in der Kamera eine Einstellung über das Format und den Codec haben. Vielleicht ist bei dir bei Video auch ein RAW Modus ausgewählt, wo er ja keinen Codec oder einen spezieller herstellerabhängigen nutzt und deshalb dann VLC Probleme hat. Dies wäre dann auch eine Erklärung warum VLC ihn nicht ermitteln kann.



    Kannst du denn die Videos mit anderen Playern abspielen?

  • Hallo Rocky4,

    ich habe weiter probiert und beim Antippen des Icon Video im PC ergab sich für ca. 2 - 3 Sekunden eine Anzeige beim Codec. Nach diesen paar Sekündchen ging diese Anzeige weg und kam bei einem zweiten Antippen auch nicht wieder. Beim Antippen anderer Icons erfolgte genau der gleiche Vorgang. Ich habe die 2 Sekunden ausgenutzt und ein Foto vom Inhalt bei Codec gemacht. Da ich hier bei Bild mein Foto nicht reinbekomme wegen seiner Größe - hier also eine Beschreibung:.


    Stream 0

    Codec: H264 - MPEG-4 AVC (Part1) (avc1)

    Sprache: Englisch

    Typ: Video

    Videoauflösung: 1920x1080

    Pufferabmessungen: 1920x1080

    Bildwiederholrate: 25

    Ausrichtung: oben links

    Grundfarben: ITU-R BT.709 Bereich

    Farbübertragungsfunktion: ITU-R BT.709 Bereich.

    Stream1:

    Codec: MPEG AAC Audio (mp4a)

    Sprache: Englisch

    Typ: Audio

    Abtastrate: 48000 HZ

    Bits pro Sample: 16

    Bitrate: 256 kB/s


    Leider kann ich mir darauf keinen Reim machen - höchstens, daß irgendetwas nicht stabil ist.


    Um noch Deine Frage zu beantworten: Auf dem PC meiner Frau (Windows 10) bekomme ich eine Wiedergabe bei den Videos.

  • Hallo Hamster,


    teste mal bitte im Windows 7 PC die Videoausgabe des VLC-Players auf D3D9 zu ändern.


    Im Menü / Werkzeuge / Einstellungen / Video-Register unter Ausgabe, anstelle "automatisch" auf "Direct3D9-Videoausgabe" ändern.

    Die Änderung speichern und den VLC-Player neu starten.


    MfG

    Thomas

  • Hallo,

    1. bei mir ist eine NVidia-Karte eingebaut.

    2. Das Ändern auf "Direkt3D9-Videowiedergabe" auf meinem PC hat leider nichts gebracht.

    3. Meine Frau hat Windows 10 Home Versinon 1803 - 64 bit. MP4-Dateien werden hier wiedergegeben mit Windows Media Player oder Film+TV.

    Die Grafikkarte ist AMD Radeon HD 7500M / 7600M Series.

    MfG

    Hamster

  • Hast du mal VLC auf den PC deiner Frau installiert und es damit mal probiert? Was sagt er dann, funktioniert es dann?


    Dass es auf den PC deiner Frau mit Windows Media Player funktioniert liegt wohl daran, dass dort irgend wann mal der passende Codec installiert wurde. Der Windows Media Player kann grundsätzlich alle auf Windows installierten Codec nutzen, der VLC Player hingegen nutzt die von Windows nicht, sondern nur die die er selbst mitbringt (zumindest war es früher so). Ich würde also erwarten, dass VLC auf den Rechner deiner Frau die Videos ebenfalls nicht abspielen kann.



    Edit:

    Sollte es so sein, kann ich dir da nur empfehlen auf deinen PC ebenfalls sogenannte Codec Packs zu installieren (z.B. Windows 10 Codec Pack oder K-Lite Codec Pack), hoffen dass dann der richtige dabei ist und es dann mit dem Windows Media Player abzuspielen.