VLC "blockiert" (?) IPTV Kanal wenn WLAN nicht verfügbar

  • Moin,


    ein seltsames Verhalten des VLCs, wenn WLAN bzw. Internet nicht verfügbar ist und man versucht einen Kanal einzuschalten.

    Wenn Windows 10 mal wieder zu "doof" war beim hochfahren das WLAN (Fritz) zu connecten.

    Oder die Telekom mal wieder gerade eine Zwangstrennung durchführt.

    Oder ich den Rechner während der WLAN Nachtabschaltung hochfahre und das WLAN eben nicht vorher eingeschaltet habe.

    Wenn das WLAN/Internet wieder aktiv ist, lässt sich dieser eine Kanal nicht mehr einschalten. Keine Fehlermeldung nichts.

    Es läuft dann lediglich endlos dieser gelbe Verbindungsversuchbalken.

    Magenta TV rtp://87.141.215.251@232.0.10.120:10000 (Pro7) z.B. im Moment mal wieder.

    Manchmal reicht es, VLC neu zu starten. Oftmals musste ich aber auch den Rechner neu starten.

    Jetzt allerdings funktioniert gar nichts mehr. Pro7 ist irgendwie blockiert.

    Ist das Problem bekannt? Setzt VLC irgendeine Art Lock auf die aktive Adresse? Kann man da irgendetwas zurücksetzen?

    Notfalls probiere ich eine Neuinstallation, aber das kann es ja nicht sein, wenn sich VLC immer so dumm verhält, ist das WLAN/Internet kurzfristig nicht on.


    Fehlerprotokoll:


    main debug: processing request item: rtp://232.0.10.120:10000, node: Wiedergabeliste, skip: 0

    main debug: resyncing on rtp://232.0.10.120:10000

    main debug: rtp://232.0.10.120:10000 is at 8

    main debug: starting playback of new item

    main debug: resyncing on rtp://232.0.10.120:10000

    main debug: rtp://232.0.10.120:10000 is at 8

    main debug: creating new input thread

    main debug: Creating an input for 'rtp://232.0.10.120:10000'

    main debug: requesting art for new input thread

    main debug: using timeshift granularity of 50 MiB

    main debug: using timeshift path: C:\Users\frosc\AppData\Local\Temp

    main debug: `rtp://87.141.215.251@232.0.10.120:10000' gives access `rtp' demux `any' path `87.141.215.251@232.0.10.120:10000'

    main debug: creating demux: access='rtp' demux='any' location='87.141.215.251@232.0.10.120:10000' file='\\87.141.215.251@232.0.10.120:10000'

    main debug: looking for access_demux module matching "rtp": 15 candidates

    main debug: net: connecting to [87.141.215.251]:0 from [232.0.10.120]:10000

    main debug: using access_demux module "rtp"

    main debug: looking for meta reader module matching "any": 2 candidates

    main debug: looking for meta fetcher module matching "any": 1 candidates

    lua debug: Trying Lua scripts in C:\Users\frosc\AppData\Roaming\vlc\lua\meta\reader

    lua debug: Trying Lua scripts in C:\Users\frosc\AppData\Roaming\vlc\lua\meta\fetcher

    lua debug: Trying Lua scripts in C:\Program Files\VideoLAN\VLC\lua\meta\reader

    lua debug: Trying Lua scripts in C:\Program Files\VideoLAN\VLC\lua\meta\fetcher

    main debug: no meta fetcher modules matched

    lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\lua\meta\reader\filename.luac

    main debug: no meta reader modules matched

    main debug: `rtp://87.141.215.251@232.0.10.120:10000' successfully opened

    qt debug: IM: Deleting the input

    qt debug: IM: Setting an input

    qt debug: IM: Deleting the input

    qt debug: IM: Setting an input

    main debug: auto hiding mouse cursor

    main debug: auto hiding mouse cursor

    main debug: auto hiding mouse cursor



    thx

  • WLAN habe ich auf oberste Priorität gesetzt. Metrik ist auf automatisch.

    Daran kann es aber auch nicht liegen. Auf einem Android Tablet kann ich Pro7 empfangen. Nur auf dem PC hat VLC irgendwas versaut, so dass ich diesen Sender nicht mehr empfangen kann. Alle anderen Sender funktionieren. Wie gesagt, Neuinstallation funktioniert auch nicht. Vielleicht speichert VLC irgendeinen Mist in der Registry? Oder im Dateisystem? Irgendwas muss VLC ja gemacht haben. Die Adressen sind auf dem Tablet und Windows Version auch identisch. Vielleicht Windows neu aufsetzen, damit VLC wieder richtig funktioniert? :thumbsup::thumbsup::thumbsup::thumbsup::thumbsup::thumbsup: Ich bin genervt!

  • Alles klar! Wie ich mir gedacht habe. Blödes VLC setzt irgendwelche Locks in der registry. Hat Spaß gemacht die registry händisch zu durchsuchen und alles was nach VLC aussah zu löschen! Danke! Da kann man ja auch nichts kaputt machen! :cursing: (waren irgendwelche AppProperties)

  • Heißt das jetzt dass nach dem löschen der Registry Keys alles wieder funktioniert?


    Falls nicht wieso bist du dir so sicher dass VLC der alleinige Übeltäter ist???


    Wenn es nur einzelne Sender betrifft solltest du erstmal sicherstellen dass die Senderinformation auch wirklich absolut korrekt ist. Also Senderliste als Datei kopieren und nicht manuell übertragen.


    Wie bitte schön hast du denn genau "WLAN habe ich auf oberste Priorität gesetzt"???


    Gerade "Metrik ist auf automatisch." sorgt in den meisten Fällen zu Problemen bei Multicast-Adressen, welche du ja eben nutzt!!! Ich habe dir nicht umsonst geraten diese manuell auf die höchste Priorität zu setzten. Wenn du nicht weißt wie dass geht musst du eben fragen! Setze sie mal für dein WLAN auf "1". Ich gehe stark davon aus, dass wenn du einfach mal die Metrik korrekt einstellst es dann auch funktionieren wird.



    Edit:

    "Daran kann es aber auch nicht liegen. Auf einem Android Tablet kann ich Pro7 empfangen." <- Was für ein Quark! Du weist schon dass Windows und Android völlig unterschiedliche System sind oder?


    Außerdem nutzt du auf deinem Smartphone sicherlich auch nur eine aktive Netzwerkschnittstelle (WLAN) und nicht wie auf deinem PC mehrere (WLAN, LAN, evt. virtuelle Netzwerkkarten). Aus diesem Grund musst du dann Andorid auch nicht sagen welche Schnittstelle zum Routen von Multicast-Addressen genutzt werden soll, wenn es halt nur eine einzige gibt. Bei mehreren kann es dann halt sein dass die falsche genutzt wird, bzw. es dann nicht mehr korrekt funktioniert wenn diese plötzlich geändert wird. Was ja scheinbar immer der Fall war, wenn es bei dir zuvor zu Problemen gekommen ist, wie du ja angegeben hast.

  • Es war definitiv ein Eintrag in der Registry. Alles gelöscht und siehe da, Pro7 läuft wieder. Habe meine Senderliste zwischendurch auch nicht angefasst...

    An meinem Laptop habe ich auch nur eine "funktionierende" Schnittstelle, eben WLAN und diese habe ich Prio 1 gegeben, damit zuerst mit dieser ein Verbindungsaufbau versucht wird.

    Kann sein, dass sich VLC "merkt", dass es zu dieser Sender-Adresse bereits einen Stream geöffnet hat und diese Info in der Registry speichert (es könnten mehrere VLC Instanzen laufen, dann wäre das ein sinnvoller Ort (habe ich gerade mal probiert, man kann mehrer Sender schauen, prima. Macht also Sinn mit der Registry)).

    [Nachtrag: Nö. macht doch keinen Sinn, denn ich kann ein und den selben Sender in 5 VLC Instanzen schauen...naja, evtl. gibt es ja einen sinnvollen Nutzen dafür]

    Irgendwas ist dann halt passiert, das VLC diesen Lock nicht wieder löschen konnte, wollte. Also händisch aus der Registry entfernt und - oh Wunder - Pro7 konnte wieder eingestellt werden. Ist natürlich ziemlich mies, wenn einer das nicht kann, will oder gar sein System dadurch zerschießt. :cursing:

  • Naja, man hätte sich den Eintrag in der Registry ja einfach nur mal anschauen müssen was er macht... Oder posten, damit sich andere diesen mal anschauen können...


    Deine Aussage von nur einer funktionierende Schnittstelle deutet ja auch mehrere hin und nur weil eine andere Schnittstelle für dich nicht mehr funktioniert, heißt es nicht dass dies auch für Windows oder Programme gilt!


    Wie genau du WLAN Priorität 1 gegeben hast, hast du ja immer noch nicht geäußert, trotz dass ich dich darum gebeten hatte.