Ruckeln bei aktiver Bild-Justierung

  • Hi,


    wenn ich 4K-Videos abspiele und die Bildjustierung aktiv habe, ruckelt der Film. ;( Der Taskmanager zeigt folgende Werte für die Systemauslastung(wenn Bild-Justierung an):


    CPU ~35%

    RAM ~45%

    GPU ~20%

    HDD ~1%


    Da sind also noch Ressourcen frei, aber warum ruckelts? Kann man da irgendwie durch Einstellungen ein wenig tricksen? Habe alle Einstellungen auf standart.


    System Specs:

    OS: Win10 Home

    CPU: i5-6400

    RAM: 8 GB DDR4 @ 2133MHz

    GPU: GTX 1050TI


    Verwendet wird der VLC 3.0.6

    MfG, Noide

    Quote from Edmund Burke

    Für den Triumph des Bösen reicht es, wenn die Guten nichts tun!

    Wehrt euch gegen den Überwachungsstaat!

    Edited once, last by NoIde ().

  • Moin thweiss,


    habs direkt mal probiert, mit DX9 funktioniert die Bildjustierung nicht(BUG?), habe DX11 probiert, gab eine kleine Linderung, aber es ruckelt noch sichtbar. Ich versteh das nicht, der Rechner ist ~3Jahre alt, wurde dick und fett mit 4K-tauglichkeit vermarktet, hab noch eine bessere GPU reingemacht und dann muss ich wenn der Film mal zu dunkel ist, den Monitor heller machen anstatt nur temporär die VLC Bildjustierung zu nutzen ;(. Bei FHD klappt das noch wunderbar, naja sind da ja auch nur etwa 1/4 der Daten im gegensatz zu UHD zu verarbeiten.


    Ich habe noch 2 Vermutungen, die GPU schliesse ich mal aus, habe die auch mal übertaktet(Asus GPU Tweak 2), wird nicht besser, nicht mal minimal. Kürzlich habe ich gelesen das ein Windows-Update auf die Performence des Systems haut(KB4482887), soll sich eigendlich beim spielen mit FPS-Drops bemerkbar machen, beim spielen habe ich zwar nichts bemerkt, aber ich deinstallier mal dieses Update. Die andere Vermutung ist die CPU, die schafft ja nur 4 Threads, auch wenn die nicht voll ausgelastet ist, kann es sein, das da was im Argen liegt.


    Edit: Am Update KB4482887 liegt es nicht||

    MfG, Noide

    Quote from Edmund Burke

    Für den Triumph des Bösen reicht es, wenn die Guten nichts tun!

    Wehrt euch gegen den Überwachungsstaat!

    Edited 2 times, last by NoIde ().

  • Programmfehler werden immer wiedre festgestellt. Es muss nicht immer am VLC-Player liegen.


    Habe noch einen Hinweis gefunden, den man ausprobieren könnte.


    In den erweiterten Einstellungen für FFMPEG nur einen Thread zulassen.

    Menü / Werkzeuge / Einstellungen - Alle / Eingang-Codecs / Videocodecs / FFmpeg in der rechten Spalte unter Threads anstelle der Null eine 1 eintragen.

    Siehe Bildschirmausdruck "VLC306-4k-FFMPEG-Thread.png"


    Die Änderung speichern und den VLC-Player neu starten.


    Siehe dazu auch den Link: https://forum.videolan.org/viewtopic.php?t=146683


    MfG

    Thomas

  • Also hab das auch mal probiert, bringt alles nichts. Ich habe gerade ein Stück von dem Video ausgeschnitten(remuxed), also ohne Bild und Ton zu verändern. Ein Kollege war so nett und hat sich das von mir geladen(hab lokalen Webserver hier laufen), bei ihm ruckelt es nicht. Er hat ein identisches System, abgesehen von der CPU und HHD's, der hat eine i7 7700K.


    Scheint als ob ich aufrüsten muss, also neues Board+CPU. CPU für LGA1151 lohnt sich ja nicht mehr, passt ja nur bis 7.Generation, danach ist ja LGA1151 V2.


    Also natürlich habe ich auch mal die meldungen angeschaut, keine Fehler, aber Warnungen und debug-meldungen ohne Ende:



    So geht das die ganze Zeit.

    MfG, Noide

    Quote from Edmund Burke

    Für den Triumph des Bösen reicht es, wenn die Guten nichts tun!

    Wehrt euch gegen den Überwachungsstaat!

    Edited once, last by NoIde ().

  • Das Protokoll kann man z.B. als Textdatei der nächsten Antwort hinzufügen.


    Im Menü / Werkzeug / Meldungen die Ausführlichkeit auf die Stufe 2 stellen und ggf. die Bildjustierung im VLC-Player bereits aktivieren.


    Danach das 4k Video starten und das erstellte Meldungsprotokoll als Text-Datei speichern.

    Einige Sekunden Videowiedergabe sollten für das Protokoll reichen.


    Vielleicht kann man so aus den Meldungen etwas mehr erkennen.


    MfG

    Thomas

  • Ok, hatte die Meldungen erst nach dem das Video lief aufgemacht, jetzt wo das Fenster schon auf war, steht schon mehr drin, aber mir sag es nicht viel.

    Files

    • log.txt

      (82.86 kB, downloaded 55 times, last: )

    MfG, Noide

    Quote from Edmund Burke

    Für den Triumph des Bösen reicht es, wenn die Guten nichts tun!

    Wehrt euch gegen den Überwachungsstaat!

  • Hallo Nolde,


    habe jetzt mehr Informationen zum *.mkv-Video mit h.265 Codec und dem NVidia Grafiktreiber "25.21.14.1935".


    Einige Audio-Fehler sind zu finden, die möglicherweise mit DTS zusammenhängen.

    Code
    1. ...
    2. main debug: using packetizer module "dts"
    3. main debug: looking for audio decoder module matching "any": 23 candidates
    4. main debug: reusing audio output
    5. main error: module not functional
    6. main error: failed to create audio output
    7. ...

    Aufgefallen ist mir auch die Meldung direct3d11 debug: Detected size change 1920x800 und main debug: VoutDisplayEvent 'resize' 1920x925 die aus meiner Sicht nicht zu einem 4k Video passen.


    Möglicherweise hängt das Problem generell mit dem *.mkv-Container zusammen.

    https://forum.videolan.org/viewtopic.php?t=147035


    Soweit meine ersten Erkenntnisse.


    MfG

    Thomas

  • Zu den 4K untypischen Werten:

    Das liegt vllt. daran das der Monitor nur FHD-Auflösung hat, hab so einen Bi-Direktionalen HDMI-Switch um auf den TV umschalten zu können bei bedarf, der kann 4K, ist aber auch am ruckeln, beim Video schauen ist bei dem Film unten und oben so ein schwarzer balken, die kann man in der Videodatei ja aussparen. Ist sogar gut, denn sonst hat man die Balken ein wenig heller(richtung grau) wenn man die Bildjustierung zum heller machen nutzt. Wobei man die auch wieder wegschneiden könnte(Default taste C für bescheiden wiederhohlt drücken) Daher auch nicht ganz die FHD Auflösung in der Höhe. Auf dem Bild im Anhang, ist zu sehen, das der VLC die Auflösung schon richtig erkennt.



    Zu MKV

    Das scheint bei mir in der Tat an dem Matroska-Container zu liegen(evtl. auch h265), hab mir jetzt so ein MP4 4K-Testvideo runtergeladen, da ruckelt es nicht. Ich hatte jetzt 5 VLC-Instanzen laufen, alle das 4K-Video mit Bildjustierung, mit 4 Instanzen alles Top, erst mit der 5. Instanz gab es erste Ausfälle beim rendern.


    Ich dachte schon der Rechner war ein Fehlkauf, war ja auch nicht so teuer, damals gesamt ~750€. Danke thweiss, du hast mir jedenfalls ein paar Hundert Euronen erspart, ich hätte jetzt echt in neue Hardware investiert, obwohl die vermutlich doch noch 1-2 Jahre brauchbar ist. Das hätte ich so jetzt nicht erwartet.


    Hatte auch noch Win10 an sich in Verdacht(in der Kombination mit meiner nicht so leistungsfähigen Hardware), da ich kürzlich wegen des baldigen Support-Ende von Win7;( [R.I.P.] auf 10 rauf bin. Würde ich nicht daddeln, wäre ein Linux für mein Hauptsystem zum Einsatz gekommen.


    Danke für deinen Support.:thumbsup:


    MfG

    NoIde


    Nachtrag:

    Ich werde auch mal schauen, ob es mit h265 und MP4 auch klappt.


    Nachtrag zum Nachtrag

    Ich hab so ein 4k h265 MP4 video gefunden, läuft wunderbar. Dann liegt das in der tat am Matroska-Container.

  • Ich habe gerade zufällig auch eine Lösung gefunden welche bei mir Funktioniert(mit der Latenz teste ich auch noch), habe für meine Grafikkarte ein neues Profil(für Leistungseinstellung, Asus GPU Tweak 2) angelegt, alle Werte niedrig(minimum) eingestellt, tuckert jetzt mit ~1400MHz GPU und ~6300MHz GPU-RAM Takt rum, siehe da, es ruckelt nicht, verstehe nur nicht, warum das bei Standarteinstellungen geruckelt hat, wie auch mit hohen Werten.

    MfG, Noide

    Quote from Edmund Burke

    Für den Triumph des Bösen reicht es, wenn die Guten nichts tun!

    Wehrt euch gegen den Überwachungsstaat!

    Edited 5 times, last by NoIde ().