VLC Wiedergabe im portrait mode (hochformat) wird nur als Quadrat wiedergeben

  • Hallo,


    versuche vergeblich die Wiedergabe richtig darzustellen.


    Aufbau: Raspberry pi im Portrait mode über /boot/config.txt und display_rotate=1

    Dort wurde folgender Befehl gestartet:


    cvlc udp://@:1234 --fullscreen --ignore-config --aspect-ratio 9:16


    die Versuche wurden auch schon mit anderen werten 16:9 ohne den Befehl und ohne fullscreen durchgeführt.

    Die Stream Quelle ist im portrait Format


    Fehler: Der Stream wird geöffnet im no-fullscreen ist die Fenstergröße passend jedoch ist das Video nur so hoch wie es auch breit ist der untere Bereich ist schwarz.

    mit vlc statt cvlc habe ich ein landscape schwarzes Fenster mit einem Quadratischen Video oben in der mitte.


    Der Versuch über den Start über SSH auszulösen führt zum gleichen Problem.

    beim zurückstellen auf landscape mode wird das Video komplett angezeigt natürlich ist dann links und rechts der schwarze Balken, da das Format dann ja nicht passt.


    Müssen noch weitere Einstellungen mitgegeben werden?

    Muss am Stream "Sender" noch etwas angepasst werden?


    ich bin für alle Hinweise dankbar.


    Grüße Jörg

  • gerade habe ich noch einene weitere Feststellung gemacht:


    mit --aspect-ratio 1:1 wird alles dargestellt.


    Jedoch bleibt es bei dem gleichen Quadrat jetzt mittig oben und unten schwarze Balken.


    das Video ist nicht mehr abgeschnitten sondern in der höhe gestaucht.


    ich denke das es nur ein kleiner Wert ist der nicht passt... ggf. kann man

  • Hallo Jörg,


    in der Kommandozeilenhilfe findet man die möglichen Optionen und Hinweise.

    - https://wiki.videolan.org/VLC_command-line_help/


    Bin mir nicht sicher, ob die Option --ignore-config benötigt wird.

    Funktioniert es auch ohne diese Option?


    Man kann ja mal ausprobieren die Einstellungen im VLC-Player zurücksetzen mit der Option --reset-config.

    So sollten versehentlich gesetzte Einstellungen verschwinden.


    Für das Bildseitenverhältnis --aspect-ratio kann man noch andere Werte ausprobieren, damit die aufgetretene Bild-Verzerrung verschwindet.

    Unter Windows lassen sich mit der Taste [ A ] die verschiedenen Bildseitenverhältnis aufrufen.

    - https://wiki.videolan.org/QtHotkeys/


    Soweit die ersten Ideen.


    MfG

    Thomas

  • Gog01

    Changed the title of the thread from “VLC Stream im portrait mode (hochformat) wird nur als Quadrat wiedergeben” to “VLC Wiedergabe im portrait mode (hochformat) wird nur als Quadrat wiedergeben”.
  • Hallo Thomas,


    Vielen Dank für Deine Nachricht.


    Die Hilfe ist mir bekannt daher habe ich auch die Parameter. das ingnore-config habe ich nur hinzugefügt um zu zeigen das alles auf Standart eingestellt ist.

    Es hat sich was geändert:

    gerade musste ich feststellen das dieses problem auch lokal beim Abspielen auftritt und kein problem mit dem Streamen an sich ist.


    da das Bild Quadratisch ist denke ich das irgend ein Wert sich nicht mit dreht wenn das Bild gedreht wird.


    Die Grafik gibt jedoch alles aus...

  • Hallo Jörg,


    hast du auch mal in Raspberry Foren nach Hilfe gesucht?

    Ich habe im Moment keine Idee, was man im VLC-Player noch ausprobieren könnte.


    Will mal einen Link zur Thematik ergänzen.

    - https://tutorials-raspberrypi.…raspberry-pi-touchscreen/


    Eventuell findet man im Raspberry-Forum eine Lösung.

    - https://forum-raspberrypi.de/forum/board/86-raspberry-pi-3/


    Habe doch noch einen Hinweis gefunden, wo das Thema von den Entwicklern bereits erfasst ist.

    - https://trac.videolan.org/vlc/ticket/22128


    Dazu gibt es den passenden Thread, zum nach verfolgen.

    - Raspberry Pi VLC Fullscreen with Aspect Ratio problem


    Mehr kann ich im Moment nicht tun.


    MfG

    Thomas