DVD Video Audio Sprache konvertieren

  • Hallo,
    es soll aus einer Video-DVD die deutsche Audio-Spur
    entnommen und gespeichert werden.


    Im DVD-Menü ist an der ersten Position Englisch als Sprache zu sehen.
    Im Medium/Öffnen Menü des VCL wird jetzt als Audiospur die 2 gewählt,
    das ist ja der zweite Eintrag für Deutsch im DVD-Sprach-Menü.
    In der Konvertieren/Speichern Liste wird Konvertieren gewählt.
    Und als Profil bei den Einstellungen Audio-MP3 (MP4).


    Der Player erzeugt jetzt eine eine Audio-Datei im mp4 Format.
    Aber die Sprache ist immer Englisch. Es kommt kein Deutsch-Track.
    Was kann man tuen?

  • Hallo vlchp,


    Du schreibst:

    Quote

    Im Medium/Öffnen Menü des VCL wird jetzt als Audiospur die 2 gewählt, das ist ja der zweite Eintrag für Deutsch im DVD-Sprach-Menü.

    Hast Du es auch einmal mit einer anderen Audiospur als der 2 probiert. Zweiter Eintrag in der Auswahl ist eine Sache, tatsächlicher Audiostream die andere.


    Mit freundlichem Gruß,


    kodela


    Nachtrag:


    Hast Du die DVD schon einmal in die Wiedergabeliste geladen und dort über das Kontextmenü - Information... - Codec nachgesehen, welche der Streams vom Typ "Audio" sind?

  • OK.


    Auch wenn eine andere Audiospur Nr. ausgewählt wird,
    ist das Ergebnis Englisch.


    Im Kontexmenü - Informationen sind diese Sreams zu sehen:
    Stream 0, Type Untertitel
    Stream 1, Type Video.
    Also keine Audio-Typs.


    Gruß

  • Hallo vlchp,


    was ist zu sehen, wenn Du bei Einstellungen - alle - Input/Codecs die Option "Bevorzuge native Streamaufnahme" selektierst?


    Andere Frage: Dass auf dieser DVD sich auch wirklich die deutsche Sprache einstellen lässt, hast Du schon ausprobiert?


    Mit freundlichem Gruß,


    kodela

  • Bei Einstellungen - alle - Input/Codecs gibt es die Option "Bevorzuge Videoauflösung".
    Eine Option "Bevorzuge native Streamaufnahme" sehe ich nicht im Moment.


    Ja, wenn man im Start der DVD Deutsch anwählt, spielt sie auch in deutsch ab.


    Da das eine DVD aus 2001 ist, versuche ich es mit einer anderen aus 2011.
    Hier ist auch bei den Codecs ein Type Audio zu sehen.
    Es gibt hier: die Streams 1 bis 5, Type Audio, Sprache: Englisch, Englisch, Francais, Espanol und Deutsch.


    Gruß

  • Hi,


    bin noch dabei.
    Wie gesagt, eine DVD aus 2011,
    Gehe mit den gleichen Einstellungen vor wie beschrieben.


    Es scheint so zu sein, das die einzelnen Sprachen jetzt eine Datei machen.
    Ja, englisch, französisch und spanisch ist schon extrahiert,


    Erfolg! Gut gemacht kodela!


    Gruß

  • Hallo vlchp,


    dann ist ja alles ok!

    Quote

    Bei Einstellungen - alle - Input/Codecs gibt es die Option "Bevorzuge Videoauflösung".
    Eine Option "Bevorzuge native Streamaufnahme" sehe ich nicht im Moment.

    Die Option "Bevorzuge native Streamaufnahme" ist bei Version 2.0.3 im Abschnitt Einstellungen - alle - Input/Codecs in der sechsten Zeile von unten.


    Mit freundlichem Gruß,


    kodela

  • Hi kodela,


    hier wird die Version 2.0.4 verwendet.
    Das erwähnte "Bevorzuge native Streamaufnahme" ist hier def.
    nicht vorhanden. Auch nicht in der sechsten Zeile von unten.


    Gruß

  • Hallo vlchp,


    da muss ich bei Gelegenheit einmal nachsehen, wo in Version 2.0.4 die Option "Bevorzuge native Streamaufnahme" versteckt wurde. Es handelt sich hier übrigens um eine sehr wichtige Option, die ich bei mir immer wieder, je nach Situation, umstellen muss.


    Für die Aufnahme von DVB-Videostreams sollte sie deaktiviert werden, da in einem solchen Stream meistens über zwölf Einzelstreams eingebunden sind, vier Video-Streams pro Frequenzband und dazu die Audio- und Untertitelstreams. meistens kommen da noch einige andere dazu, so dass es bis zu 20 Streams in einem werden können.


    Hat man nun die Option "Bevorzuge native Streamaufnahme" selektiert, dann werden, auch wenn man nur einen Sender aufnehmen will, alle gleichzeitig auf diesem Frequenzband eingebundenen übrigen Sender mit aufgezeichnet, was den Stream naturgemäß ganz schön aufbläht.


    Anders ist das wieder zum Beispiel bei der Aufnahme einer DVD. Da hatte ich schon den Fall, dass bei nicht selektierter Option "Bevorzuge native Streamaufnahme" nur das Video, nicht aber der Audiostream gespeichert wurde. Das ist nicht immer so, aber mir ist es passiert und ich habe ganz schön lange nach der Ursache gesucht.


    Mit freundlichem Gruß,


    kodela

  • Hallo vlchp,


    Du hast geschrieben:

    Quote

    hier wird die Version 2.0.4 verwendet.
    Das erwähnte "Bevorzuge native Streamaufnahme" ist hier def.
    nicht vorhanden. Auch nicht in der sechsten Zeile von unten.

    Da, wie erwähnt, es sich bei dieser Einstellung um eine relativ wichtige handelt, habe ich die bei mir einwandfrei funktionierende Version 2.0.3 deinstalliert und die nicht einwandfrei funktionierende Version 2.0.4 installiert, um dort nach der Option "Bevorzuge native Streamaufnahme" zu suchen.


    Und wo fand ich sie, genau dort, wo sie nach meiner Beschreibung sein sollte, im Abschnitt Einstellungen - alle - Input/Codecs in der sechsten Zeile von unten.


    Hier kannst Du einen Screenshot dazu sehen:



    Ich frage mich schon, warum ich mir diese Mühe machen musste. Jetzt darf ich die Version 2.0.4 wieder deinstallieren, die Version 2.0.3 installieren und die beiden Dateien für den Download von YouTube wieder dorthin kopieren, wo sie hingehören. Da kommt bei mir so richtig Freude auf.


    Mit freundlichem Gruß,


    kodela


    PS:
    Wenn Du nicht mit Windows arbeiten solltest und unter dem von Dir verwendeten Betriebssystem das anders aussehen sollte, dann entschuldige bitte meine Häme. Dann hättest Du aber auch darauf hinweisen können.

  • Es geht hier
    um einen Eintrag bei den Extras->Einstellungen->Alle->Input/Codecs
    der Windows Version 2.0.4 des VLC. Kodela hat sich einige Mühe damit gemacht
    herauszufinden, wo sich die Option "Bevorzuge native Streamaufnahme" befindet.
    In seinem Sceenshot zu sehen. Hier ist die Options-Lasche in dieser Version.
    Sieht sehr unterschiedlich aus. Besagte Option muss wohl unter einer anderen
    Bezeichnung vorhanden sein.


    Wer weiß wo?

  • Hallo vlchp,


    ja, genau so wie auf Deinem Bild sieht es bei mir auch aus, aber nicht nur so!


    Im Unterschied zu Dir habe ich die Scrollleiste am rechten Rand nicht übersehen. Ziehe die doch einmal nach unten, und sage mir, was Du dann siehst.


    Ich wünsche Dir ein gutes Neues Jahr,


    kodela