Posts by Pit Zyclade

    Nach meinen Versuchen fehlt der notwendige codec, weshalb ich das Thema/Lemma neu schuf.
    Das kritische File allerdings ist ebenfalls korrupt. Nach Zerlegung konnte ich es im 'Magix Video deluxe' bearbeiten.
    Ich habe keine neuen codec-Packs geladen, weil manche Seite von meinem avira als gefährdet oder mit Malware belastet gemeldet wurden.
    Solange ich keinen mp4a-codec für meine Version habe, wird es nicht klappen. Dazu aber mehr im anderen thread.
    Danke an alle.

    A) Ich lade mal das Bild hoch, welches erläutern sollte, dass die angegebenen Optionen bzw. Parameter bei meiner Version nicht so zu finden sind, wie angegeben.
    B) Es sieht so aus, dass ich den codec mp4a nicht habe.
    C) Zu Deinem avi-Beispiel. - Mein Ziel war es ursprünglich, die avis ohne Umkodieren zu schneiden. Dat tat ich früher mit Freevideodub. Das geht rasend schnell. Die Teilstücke waren dann meine Sicherung. Erst danach machte ich per Stapelverarbeitung mit VLC die mp4. - Nun habe ich mit einem avi mal Deine Option avi(h264+wma2) versucht. Leider bekomme ich da irgendwie keinen Videostream rein. Auf der anderen Seite, als ich meinen fehlenden Ton beklagte, da funktionierte H264 aber sehr gut. Es kann dann doch nur an der Kombination liegen.
    Dann habe ich beim dritten Versuch die audiosamplingrate auf 8000 runtergesetzt. Dann kommt ein pixeliges video und eine Tonspur nicht optimaler Qualität. Also ist das Zusammenspiel das Problem.
    Mit dieser Schlußfolgerung kann ich ja noch weiter experimentieren. Auch muss ich überprüfen, ob nun der Player (nicht VLC) dieses Format kann...

    Danke für Deine zwei Antworten. Nun ja, ist ein Wiedergabegerät. Aber für meine wenigen Heimkamera-Videos hatte er sehr guten Dienst geleistet, insbesondere als mein Rechner vor mehrere Kassetten per Stapel die Nacht über arbeitete. Heute ist alles schneller, leider auch die Alterung und auch die Entwicklung, so dass Rechnertausch mehrfach erfolgte und nun auch manches Programm nicht mehr arbeitet. Gestern hatte ich noch versucht einen freeware Programm zum avi schneiden upzudaten (komische Sprachentwicklung). Leider war die webside bereits verseucht, so dass avira mich warnte und so kam das Programm "in Quarantäne".


    (Die Zeit läuft davon. In den neuen Geräten vermißt man manchen Komfort älterer Geräte, dafür wieder neue Optionen, an die man nie dachte und sich gewöhnen muß. Das ist beim Auto ebenso wie bei den Hauswirtschaftsgeräten und sogar beim TV. Ich habe mir wegen der Enkel, die in den Ferien kommen wollen, einen neuen BR-DVD-Player angeschafft. Nun kann der mit USB sogar als schneller Mediaplayer arbeiten, so dass die alten mp4 wieder aktiviert und sortiert werden sollten. Dann kam ich auf die Aufnahmen, die Fehler hatten, nicht korrekt geschnitten wurden usw. Zwar habe ich sogar ein Magix Video deluxe, nur manches geht nicht oder ich habs noch nicht raus. Avis schneiden kann er, aber wieder als avi exportieren kann er nicht, ebenso wie VLC. Nun dachte ich, machs wie früher, also VLC Richtung mp4...)


    Zu Deinem Hinweis "Wie richte ich mir den VLC ein?". Dort wird ein Hinweis gegeben, der bei mir (VLC 2.2.1 64 bit, extra gestern neu installiert) so nicht nachvollziehen kann, ich meine die codec-Einstellung sieht bei mir anders aus. (Wie fügt man in diesem Forum ein Bild ein? URL wie? Man kann sich nicht zum Bild hinhangeln? Schade)

    Mein VLC (sowohl 32 bit letzte Version, als auch der 64bitige) vermißt beim trancoding diesen mp4a-Codec.
    Ich dachte immer, VLC bringe alle codecs, die VLC empfiehlt, selbst mit. Jetzt werde ich eines besseren belehrt.
    Also wie macht man es, um im normalen Stremel weiterzufahren, wenn man mp4/AVC/AAC zusammenbringen will?

    Ich werde Deinem Hinweis zum "Teil 3" noch folgen...
    Irgendetwas stimmt mit dem acodec nicht. Wenn ich per Menü nämlich die andere Option mp4audio dazu wähle, dann wird gemeldet, dass der namentlich in meiner Kommandozeile gewählte mp4a nicht geöffnet werden könne. Also passt der nicht oder ist nicht vorhanden.
    Im wiki unter MPAG-4 ist ein Beispiel, wo er bei transcode verwendet wird. Also offenbar gibt es ihn und nur die Kombination stimmt nicht?
    Ich hatte früher und auch jetzt im wiki nachgelesen, nur bedauerlicherweise gibt es im wiki unter "command-line help" bei den vielen Optionen (fast) nie ein Beispiel (das ist nach meiner Meinung ein großer Mangel!).
    Ein weiterer Mangel nach meinem Gefühl ist, dass bei Methode per Menü die Optionen nicht offenbaren, welche codecs verwendet werden, so wie diese dann in der Kommantozeile heißen. Anders gesagt, man hat ein gutens Resultat per Menü und kann es mangels Übersetzung nicht in Kommandozeile umsetzen.
    Ich hatte meinen Weg so organsiert, dass ich das funktionierende Resultat mit mediainfo überprüfte. Das hatte ich vor meiner Eingangsfrage schon getan.
    Den Dummy auszuschalten bringt leider mir nichts, weil die Kommandozeile bei dem vorliegenden batch bereits geschlossen ist, bevor man gelesen hat... muß also auch da nochmal umstricken...
    MfG
    Pit

    Bitte keine Einführung. Ich nutze VLC seit Jahren bestens und auch zum Transcodieren. Ich weiss sehr wohl, wie eine Kommandozeile und Batchprogramming (...cmd) von VLC unter win7 funktioniert.
    Dass alles auf einer Zeile stehen sollte, ist bekannt. Aber man kann mit ^ vor Zeilenumbruch die Zeile maximal ausnutzen.
    Wenn die gesamte Zeilenlänge ausgeschöpft wäre, dann doch nicht genau nach vcodec..., denn die Tatsache, dass das Zielfile mit richtigem Namen und an richtiger Stellle und mit korrekten Videoparametern erzeugt wurde, läßt schlußfolgern, dass der Befehl akzeptiert wurde.


    Mein Ziel? Ich möchte auf Knopfdruck mein Programm aufrufen, weil man im Alter nach Monaten wieder spezielles vergißt und nicht alle 2 Jahre, solange ich lebe, denselben Schwachsinn erfinden will. Ich habe ein Programm in REXX, das kennen wohl die wenigsten noch, geschrieben, dass auf das Batchprogramm zugreift. Da dieses komischerweise nicht mehr will, bin ich auf den Batch-Kern zurückgegangen, um den Fehler zu finden. Im Augenblick will ich Videofiles von miniDV-Kassette (dher die Auflösung) von avi in ein mp4 umformen. Dabei wäre es optimal durch Eingabe der Zeieten zu schneiden, was für die Videopart auch funktioniert.


    Den Test-code avi2mp4.cmd nochmals (die Markierung hier oben im Editor funktioniert nicht so, wie ich es mächte):


    for %%a in (*.avi) do cmd /c "C:\program files (x86)\VideoLan\VLC\vlc.exe" ^
    -I dummy -vvv %%a ^
    --start-time=14 --stop-time=74 ^
    --sout=#transcode{vcodec=h264,vb=7000,fps=25.000,width=722,height=578,size=4:3,deinterlace=1,acodec=mp4a,ab=128,channels=2,samplerate=48000,}^
    :standard{access=file,mux=mp4,dst=VLCout\%%~na.mp4} ^
    vlc://quit


    Und die Frage, wie ich das gültige File über die Menüs erzeugte?
    Konvertieren/Speichern->G:\195800_O4DV.avi
    Verkapserlung mp4/Video H-264 , Bildwiederholrate wie Quelle/Audio MPEG-Audio, bitrate 128,Kanäle 2, Abtastrate 48000

    Hallo,
    Ich bin am Verzweifeln, weil ich in meinem batchprogramm den Fehler nicht finde.


    Input
    ist ein File: avi, 1 video, 1 audio
    video:
    720 x 576, 4:3, 25000fps, DV(PAL)
    audio:
    48kHz, 16bit, 2 channels, PCM(DV)
    im VLC-Player ist es gut hörbar


    Ich nutze zwei Wege
    A) Per Menü im VLC
    Resultat:
    MPEG-4(mp4),
    1 video AVC, 1 audio MPEG Audio
    video: 720 x 576, 4:3, 25000fps, AVC(PAL)
    audio: 128Kbps, 48kHz, 2 channels, MPEG Audio
    Dieses File ist im VLC-Player gut hörbar!


    B) mit batchprocessing auf der Kommandozeile umgeformt:
    for %%a in (*.avi) do cmd /c "C:\program files (x86)\VideoLan\VLC\vlc.exe" ^
    -I dummy -vvv %%a ^
    --start-time=14 --stop-time=350 ^
    --sout=#transcode{vcodec=h264,vb=7000,fps=25.000,width=722,height=578,size=4:3,^
    acodec=mp4a,ab=128,channels=2,samplerate=48000,deinterlace=1}^
    :standard{access=file,mux=mp4,dst=VLCout\%%~na.mp4} ^
    vlc://quit


    Resultat:
    Es wird am richtigen Ort ein file produziert
    Mpeg-4(mp4),
    1 video AVC, kein audiostream
    Video:AVC, 720 x 576 , 4:3, 25000fps, AVC(PAL)


    aber logischerweise ohne Ton !!!


    Wo liegt mein Fehler, dass ich keinen audiostream im mp4 habe?


    Danke für jede Anregung, denn ich habe schon einen ganzen Tag mit Fehlersuche verplempert...