Posts by ninjagame

    Hallo Thomas,


    inzwischen hab ich 3.0.3, und Stand in diesem Augenblick scheint es mit dem Aufnehmen tatsächlich wieder zu funktionieren.

    Natürlich nicht ohne dass VLC (oder ist es Windows?) eine kleine Extrawurst braten möchte: Ich habe innerhalb des Ordners "Eigene Videos" einen weiteren (Unter-)Ordner definiert, in dem Aufnahmen abgelegt werden sollen, und den entsprechenden Pfad in den Prefs eingegeben. Bisher legt VLC die Aufnahmen jedoch stur in "Eigene Videos" ab. Vielleicht experimentiere ich später noch ein bisschen damit herum.

    Es kann aber auch sein, dass - zumindest unter Windows, zumindest bis VLC 3.0.2 - selbst dann keine Aufnahme abgelegt wird, wenn ein Verzeichnis eingetragen ist. Laut dem englischen Forum soll das angeblich mit 3.0.3 behoben sein, aber ich hatte noch keine Gelegenheit, es auszuprobieren, da der Admin in meiner Firma diese Version noch nicht installiert hat.

    Zum Thema "Aufnehmen funktioniert nicht" unter Windows scheint es eine Lösung zu geben:

    https://forum.videolan.org/viewtopic.php?f=14&t=142645

    Vielleicht hilft das ja jemandem weiter.


    Nachtrag: Bei mir hilft's leider nicht.

    Auf meinem Rechner ist der "Windows Defender" aufgrund einer Firmenrichtlinie deaktiviert. Von daher dürfte das eigentlich nicht das Problem sein. Trotzdem kann ich nach wie vor nichts aufnehmen bzw. Aufnahmen werden nicht gespeichert.

    ergo-hh

    2 unterschiedliche Dinge.

    Zu Hause, auf meinem MacBookPro, funktioniert alles, wie es soll. Wenn ich dort mit CMD-Alt-R eine Aufnahme beginne, wird der Download des Streams im Ordner "Downloads" gespeichert, und zwar wird so lange gespeichert, bis ich erneut Cmd-Alt-R drücke. Dann ist die Aufnahme beendet, und ich kann die gespeicherte Datei verwenden (z.B. noch einmal abspielen).

    Im Büro, wo ich eine Windows-Maschine habe, habe ich mir unter Tools -> Einstellungen -> Eingang/Codecs einen Speicherort gewählt, und bisher sind Aufnahmen dort auch immer abgespeichert worden. Zum Starten und Beenden der Aufnahme benutze ich jeweils Ctrl-Alt-R. Dass eine Aufnahme "läuft", erkenne ich z.B. daran, dass der "Aufnehmen"-Button links unten blau hinterlegt ist; wenn die Aufnahme beendet ist, ist der Button wieder weiß.

    Nur ist seit VLC 3.0.0 an dem definierten Speicherort nichts mehr abgespeichert - auch an keinem anderen Speicherort, der mir so einfällt (z.B. "Downloads").

    Wenn ich mit der rechten Maustaste in den VLC-Screen klicke, bekomme ich gar nicht die Option "Speichern", sondern nur "Aufnehmen".

    Ich habe sogar schon versucht, den Pfad zum Speicherort zu löschen, um damit die Frage nach dem Speichern zu provozieren. Es passiert aber nichts.

    ergo-hh :

    Mit "Aufnehmen" meine ich, dass Streams, die ich, sagen wir mal, "abgreifen" möchte (Strg-Alt-R oder in den roten Aufnahmebutton links unten klicken), nicht, wie bisher, an dem dafür definierten Platz gespeichert werden, sondern gar nicht.

    Hallo Thomas,


    vielen Dank für das Nachreichen. Ja, das hatte ich vergessen, mea culpa.

    Man sollte aber unbedingt noch auf das hinweisen, was auf der videolan-Seite auch hervorgehoben wird: Diese "nightly versions" können mit der Zeit instabil werden, und es gibt keinen Support. Es empfiehlt sich daher, sich regelmäßig die neuesten Versionen herunterzuladen (und die jeweils vorangegangene Version aufzubewahren, damit man darauf zurückfallen kann, falls in der neuesten Version etwas "verschlimmbessert" wurde).

    Viel schöner wäre es, wenn endlich eine endgültige Version 3.0 erscheinen würde - ich kann von unserem Admin im Büro nicht verlangen, eine Vorabversion zu installieren.


    - ninjagame

    Hallo U96,


    (kommt der Nick eigentlich von dem U-Boot aus dem Film "Das Boot"? Den guck ich auch sehr gerne!)


    vielen Dank für Deinen Hinweis.
    Leider hilft er mir, wie Du schon vermutet hast, so erst mal nicht weiter. Das hat, wenn ich das richtig sehe, weniger mit Windows vs. Mac zu tun als vielmehr mit der Besonderheit des Streams, den ich benutze.
    Es ist dieser hier: https://b-nhkwtvglobal-i.akama…wtvglobal/index_1180.m3u8 Alternativ dazu kannst Du auch diesen hier versuchen:
    https://nhkwtvglobal-i.akamaih…wtvglobal/index_1180.m3u8
    Wie Du siehst, ist das kein "reguläres" Fernsehprogramm. (NHK World TV ist zwar über Satellit empfangbar, was für mich jedoch nicht in Frage kommt, weil ich hier keine Sat-Schüssel anbringen darf. Also bleibt mir nur das Internet.)
    Wie gesagt: Was mich wundert, ist, dass ich den Stream mit anderen Media-Playern problemlos abspielen kann - nur eben seit gestern Mittag nicht mehr mit VLC. (Leider kann ich ihn auf anderen Playern nicht aufnehmen, was für mich aber notwendig ist, weil ich die aufgenommenen Sendungen oft erst viel später gucken kann.) Ich hab schon ganz zu Anfang überlegt, ob ich durch irgendeine unbedachte Handlung - irgendwo hingeklickt, was ich nicht hätte tun sollen - irgendwas verstellt habe, was es VLC unmöglich macht, den Stream abzuspielen - aber das Löschen der Pref-Dateien und des Cache sollte solche Missgriffe eigentlich beseitigt haben.
    Trotzdem erst mal recht herzlichen Dank für Deine Hilfe soweit. Falls Dir noch was einfällt, bin ich für jede Neuigkeit offen.


    - ninjagame

    Wie erklär ich das am besten?
    Also: Ich sitze an einem MacBookPro mit MacOS 10.11.6; meine VLC-Version ist 2.2.4.


    Ich nehme regelmäßig mit VLC über einen Livestream Sendungen eines japanischen Fernsehsenders auf. Das mache ich üblicherweise, indem ich die URL über Cmd-N eingebe oder auf die URL in der Medienbibliothek doppelklicke. Dann starte ich am gewünschten Punkt die Aufnahme mit Cmd-alt-R und beende sie später auf dieselbe Weise. Ich erhalte so eine .ts-Datei, die ich speichern und z.B. über Apple-TV abspielen kann.
    Heute früh hatte ich noch etwas aufgenommen; seit irgendwann am frühen Nachmittag geht es plötzlich nicht mehr. Statt dessen bekomme ich die Fehlermeldung "Ihre Eingabe konnte nicht geöffnet werden".
    Manchmal liegt das daran, dass der Sender die Streaming-URL ändert. Das machen sie auch gern mal mitten in einer Sendung. Macht aber nichts; in diesem Fall greife ich über Firefox die neue URL ab, und weiter geht's.
    Die Streaming-URL hat sich aber nicht geändert. Ich habe sie neu abgegriffen und eingegeben - selbes Ergebnis.
    Was mich an der ganzen Sache aber verwundert: Wenn ich die URL in Quicktime öffne, geht es. Nur leider kann man mit Quicktime nicht aufnehmen. Dasselbe gilt für eine andere Streaming-Software, AirFlick. (Leider kann man auch damit nicht aufnehmen.)


    Wer hat eine Idee, woran es liegen könnte? Was mach ich falsch?
    Ich reiche gerne noch weitere Informationen nach, die notwendig sind für eine Antwort. Ich weiß nur im Moment nicht, welche das sein könnten. Statt dessen werde ich immer verzweifelter, weil heute Abend noch einige interessante Sendungen kommen, die ich gern aufnehmen würde.


    Ach ja - was ich sonst noch versucht habe: Die Klassiker eben:


    VLC neu gestartet.
    Rechner neu gestartet.
    Router neu gestartet.
    Sogar: VLC gelöscht, neu installiert.
    Prefs auch gelöscht.


    Vielen Dank im Voraus fürs Nachdenken und für jede Hilfe!