Beiträge von albundy

    Hi

    Ich starte den VLC Stream hiermit


    Code
    1. Start "vlc" "C:\Program Files\VideoLAN\VLC\vlc.exe" --network-caching=1000 http://IP-VOM-RECHNER/X:X:X:XXX:XXX:X:XXXXX:X:X:X: --sout=#transcode{vcodec=h264,vb=5000,acodec=mpga,ab=128,channels=2,samplerate=44100,scodec=none}:duplicate{dst=http{mux=ts,dst=:8080/}}


    Würde nun aber gerne den Titel name vom VLC ändern schon in der batch datei

    wie ist denn der Befehl dafür


    Gibt es be deutsche seite mit den ganzen befehlen und erklärung dazu ?


    Danke für eur Hilfe

    Alo ich habe alle unterpunkte durchsucht nichts gefunden


    jezt ne ganz doofe frage

    Code
    1. --live-caching=0
    2. --no-sout-livehttp-caching


    beim Client einfügen


    so?

    Code
    1. "C:\Program Files\VideoLAN\VLC\vlc.exe" http://VERTEILER:8080 --network-caching=1000


    ode so


    Code
    1. "C:\Program Files\VideoLAN\VLC\vlc.exe" http://VERTEILER:8080 --network-caching=1000 --live-caching=0

    Starte auf dem Laptop den stream mit


    Code
    1. "C:\Program Files\VideoLAN\VLC\vlc.exe" --network-caching=1000 rtmp://p3-6.mov.at:1935/live/weekstream --sout=#transcode{vcodec=h264,vb=1500,acodec=mpga,ab=128,channels=2,samplerate=44100,scodec=none}:duplicate{dst=http{mux=ts,dst=:8080/},dst=display}


    Stream startet wie gewöhnlich mit Ton aber einem Standbild


    Starte ich dann auf dem Laptop


    Code
    1. "C:\Program Files\VideoLAN\VLC\vlc.exe" http://localhost:8080


    habe ich dann Auf dem Laptop ca 1 sekunde verzögerung



    auf dem PC mache ich dann


    Code
    1. "C:\Program Files\VideoLAN\VLC\vlc.exe" http://VERTEILER:8080 --network-caching=1000


    Dennoch 30 Sekunden verzögerung



    Starte ich auf dem PC den Stream als Verteiler startet wie gewöhnlich mit Ton aber einem Standbild.

    Gleiches Szenario wie auf dem Laptop und versuche vom Laptop dann drauf zu connecten ebenfallst 30 Sekunden Delay

    Der Delay Tritt nur dann auf wenn ein anderer Rechner auf dem Verteiler Connectet, egal welche Qulle ...


    Auf dem Verteiler lokal ist alles innerhalb 2-3 sekunden Delay was ja normal ist, aber warum dann im Netzwerk dann so ein großer Delay ist ...


    Es ist schon sehr komisch ...

    Also zu

    1: das dauert ca 2 sekunden bis Bild und Ton kommen

    2: Ton kommt nach ca 5 - 6 Sekunden Bild erscheint aber nur ein Standbild

    3: Der "Stream" dauert ca 1 sekunde dann kommt Bild und Ton und er ist dann auch ca 1 Sekunde hintendran

    Wenn ich mit dem VLC direkt vom Receiver schaue kein delay


    nur Delay vom Streamerver zum Endgerät

    Sehe beim Streamserver aber kein Live Bild



    Sieht bei mir wie folgt aus:


    Starte auf dem LAPTOP (Windows 10)


    Code
    1. @echo off
    2. start "" "C:\Program Files\VideoLAN\VLC\vlc.exe" --network-caching=1000 rtmp://p3-6.mov.at:1935/live/weekstream --sout=#transcode{vcodec=h264,vb=1500,acodec=mpga,ab=128,channels=2,samplerate=44100,scodec=none}:duplicate{dst=http{mux=ts,dst=:8080/},dst=display} :sout-all :sout-keep


    Stream läuft aber nur ein Standbild


    Auf dem Client PC (Windows 10, normaler Desktop PC)


    starte VLC normal ---> Netzwerkstream öffnen --- > http://IP-LAPTOP:8080

    Client braucht ca 30 sekunden zum verbinden und auch diese hinter dem LiveStream


    Habe diesen mal Paralell laufen lassen

    Also fangen wir anders an :)

    Mein vorhaben, was irgendwann auch mal geklappt hat mit der Streamausgabekette.


    Ich habe eine Drambox DM900 von dieser hole ich mir das "Signal".

    Der VLC soll denn Stream übers Netzwerk und evtl auch Internet dann verteilen.

    scale hatte ich mal wegen Bandbreite genommen und port :1234 da ich 8080 schon anderweitig vergeben habe


    Windows 10 auf server und Clinet

    VLC version 3.0.6