cam-Aufzeichnung

  • Von der Mikrofonaufzeichnung zur eingebauten "Webcam"-Aufzeichnung per Kommandozeile:


    Code
    "c:\Program Files\VideoLAN\VLC\vlc" --qt-start-minimized --sout-file-format dshow:// --sout=#transcode{vcodec=x264,acodec=mp4a,ab=256,channels=2,samplerate=48000}:file{dst=c:\\users\\Peter\\VLC\\cam_%%Y%%m%%d_%%H%%M%%S.mp4}


    Zwar erhalte ich tatsächlich ein File, mit Video- und Toninhalt, aber der Ton ist "tauchend", also die Amplitude gestaltet sich wellenförmig. Da ich dachte, es könnte an der Übertragungsgeschwindigkeit liegen, habe ich das Ziel auf eine externe USB-3.0-Festplatte gelegt. Aber das brachte keine Verbesserung.


    Hat jemand eine Idee?
    Danke

  • Hallo Bit,


    in welcher Qualität liefert Deine Cam denn den Audiostream?


    Die Werte, die Du dazu aus meinem Beispiel von der Mikrofonaufzeichnung kopiert hast, können in Deinem Fall total falsch sein. Die Samplerrate von 48000 ist für DVD-Qualität. 44100 ist CD-Qualität. Eine Webcam liefert meistens diese Qualität nicht.


    Du solltest Dir auch überlegen, ob Du hier überhaupt transkodieren sollst, oder ob es nicht besser ist, im RAW-Modus aufzuzeichnen. Probiere das alles erst einmal über die GUI, also das grafische Interface des VLC.


    MfG, kodela

  • Um die Kommandozeile auszuprobieren, ist das GUI sicher ganz günstig, aber um schnell Parameter auszuprobieren geht eine editierte Kommandozeile sicher auch schnell. Ich habe nach GUI nun mal folgende (nur befriedigende) Zeile erreicht:


    "c:\Program Files\VideoLAN\VLC\vlc" --qt-start-minimized --sout-file-format dshow:// :dshow-vdev="USB2.0 Camera" :dshow-adev="Mikrofon (Realtek High Definiti" :dshow-size=1280*720 --sout=#transcode{vcodec=x264,vb=0,scale=1,78,fps=50,acodec=mpga,ab=256,channels=2,samplerate=44100}:file{dst=c:\\users\\Peter\\VLC\\cam_%%Y%%m%%d_%%H%%M%%S.mp4}


    D.h. ich habe auf AAC erst einmal verzichtet und nutze mpga, womit der Ton recht ordentlich rüberkommt.


    Nun stoße ich mich an drei differenten Problemen, von denen ich zwei hier gleich nenne (das dritte in neuem thread: Bitrate):
    1) Das Format stimmt nicht, der Ausstoß ist immer 4:3 laut mediainfo. In der Hilfe steht, man solle scale als Fließkomma eingeben, was ich tat.
    2) Video und Ton sind häufig nicht synchron


    Danke für Anregung

  • Hallo Pit,


    was ist das für eine Webcam, kannst Du dazu einmal den Link zu einer Beschreibung, besser zum Manual, posten?


    Hast Du es auch schon einmal im RAW-Modus probiert, also Verkapselung im TS-Format, aber die Original Audio- und Videospur beibehalten?


    MfG, kodela

  • (Meine Antwort, vor 15 min geschrieben, ist fort ???)


    Ich habe kein Manual zur Kamera meines Notebooks Sony VPCSE2C5E.
    Eine Aufzeichnung mit der GUI im raw-Format (raw.ts, transcoding mit Häkchen (denn ohne geht gar nichts), aber MPSG-TS, Video ja, Originalvideo ja, Audio ja, Originalaudio ja) erbringt ein 0-Byte raw.ts, also nichts. Weiß nicht, was ich da falsch mache.

  • Habe jetzt aber (mit dem unveränderten mp4 output) einen Teilerfolg, denn für das Format ist der Input (!) wichtig, also
    :dshow-size=1280
    (läßt man den fort, dann wird nur die geringste Auflösung verwendet!)
    und
    :dshow-aspect-ratio=16:9
    (nur so kann man die Proportion waren, nicht mit der Anweisung im output)