Videos verändern und verändert speichern

  • Hallo,


    ich würde gerne mit dem aktuellen VLC player Videos meiner Canon G1X (in 1280x720) mit dem
    VLC player verändern und in eine neue Datei streamen.
    Ändern möchte ich - Gamma und Schärfe und evtl. Bildrauschen. Alles während dem normalen Abspielen
    in den Videoeinstellungen änderbar. Aber wie bzw. wo kann man das einstellen um das in der gestreamten
    neuen Datei geändert zu haben?
    Ein weiteres Problem ist, dass ich bei diesen gesteamten Videos keinen Ton mehr habe. Beim normalem ansehen höre
    ich den Ton, aber nicht in der gestreamten neuen Datei. Glaube die Canon G1X zeichnet Ton bei Videos in Stereo PCM auf.
    Wie und wo muss ich also was einstellen um den Ton zu behalten und das Bild heller und schärfer zu haben?


    viele Grüße & vielen Dank
    AJ :)

  • Hallo AJ,


    schaue Dir mal Bitte die beiden von Kodela geschriebenen VLC-Anwenderhinweise an.
    - https://www.vlc-forum.de/index…reinstellungen-speichern/
    - https://www.vlc-forum.de/index…und-Filter-Einstellungen/
    Ich bin mir sicher, dass Du hier die Lösung für Deine Frage zum Bearbeiten von Gamma, Schärfe und evtl. Bildrauschen finden kannst.


    Das zweite Problem mit dem fehlenden Ton muss an irgendeiner Einstellung beim manuellen Einrichten des Streams liegen. Hier kann ich mir nur ein Bild machen, wenn Du einmal alle deine Schritte mit dem VLC-Player möglichst genau beschreibst.


    Welche VLC-Version verwendest Du, 32 oder 64 Bit? Das Computer-Betriebssystem ist sicherlich von Microsoft?


    MfG
    Thomas

  • Danke schon mal für die Antwort.
    Leider klappt das nur teils. Habe jetzt unter Sout-Stream -> Transkodieren den String sharpen:adjust eingefügt. Des weiteren unter Video -> Filter und die beiden Filter einzeln dort im Wert eingestellt. Ein zum Test extra hoch gesetzter Gammawert hat bestätigt dass nach dem Stream Abspeichern nur die Schärfe zulegt, aber nicht das Gamma.
    Bei allen Versuchen ist der Ton in der neuen Datei weg. Ich habe unter Windows10 64-Bit die 32-Bit Version 2.2.4 Weatherwax
    installiert.
    Noch eine Idee wie das Gamma bzw. die Filter einstellbar sind und nach dem Abspielen auch 'ziehen'?
    Des weiteren der fehlende Ton...


    Ergänzung: kann sein dass das Schärfen auch nicht wirklich zieht, aber da bin ich nicht zu 100% sicher, da
    ich das nur ein wenig nachschärfen will. Vielleicht zieht beides nicht.


    viele Grüße & vielen Dank
    AJ

  • Habe jetzt unter Sout-Stream -> Transkodieren den String sharpen:adjust eingefügt.

    Hallo akj0815,


    wo hast Du die Einstellungen für das Schärfen und den Gammawert getroffen?

    Des weiteren unter Video -> Filter und die beiden Filter einzeln dort im Wert eingestellt.

    Was willst Du damit sagen? Wo hast Du was eingestellt und was war an Einstellungen durch Deine Änderungen über die Menüoption Werkzeuge - Effekte und Filter bereits vorhanden?

    Ein zum Test extra hoch gesetzter Gammawert hat bestätigt dass nach dem Stream Abspeichern nur die Schärfe zulegt, aber nicht das Gamma.

    Ein von mir durchgeführter Test mit der Version 2.2.4/32 Bit zeigt, dass bei einer Konvertierung sowohl eine Änderung der Schärfe wie auch des Gammawertes berücksichtigt werden. Auch mit dem Ton gab es bei mir keinerlei Probleme.


    Frage hast Du nach der Konvertierung alle Werte wieder zurück gesetzt, also den für Schärfen auf 0,00 und den Gammawert auf 1,00, diese Änderungen gespeichert und den VLC neu gestartet?


    MfG, kodela

  • Hallo,


    vielleicht war das ein Problem. Habe die Einstellungen zurückgesetzt und VLC neu gestartet. Jetzt scheinen beide auf meine
    Settings zu reagieren und im gestreamten Video zu sein. Nur mit dem Ton klappt es nach wie vor nicht - stumm.
    Muss ich da auch was setzen - habe auch testweise beim Audioencoder Linearer PCM Encoder gesetzt. Aber kein Erfolg.


    viele Grüße & vielen Dank
    AJ

  • Hallo,


    ich habe die Originalvideos im VLC (mit Ton) laufen lassen und bei der Information zum Video bekommt man
    angezeigt:


    Stream 0
    Typ: Video
    Codec: H264 - MPEG-4 AVC (part 10) (avc1)
    Sprache: Englisch
    Auflösung: 1280x738
    Bildschirmauflösung: 1280x720
    Bildwiederholrate: 29.970029
    Decodiertes Format: Planar 4:2:0 YUV full scale


    Stream 1
    Typ: Audio
    Codec: PCM S16 LE (sowt)
    Sprache: Englisch
    Kanäle: Stereo
    Abtastrate: 48000 Hz
    Bits pro Sample: 16


    Abgespeichert wird im Format MOV.


    viele Grüße
    AJ

  • Hallo akj0815,


    experimentiere mit den Profileinstellungen. Erstelle Dir dafür ein neues Profil und nenne es zum Beispiel "Mein Profil".

    • Für Verkapselung MP4/MOV wählen.
    • Für Videocodec selektiere Video, stelle als Codec H-264 und für Bitrate Nicht benutzt ein.
    • Für Audiocodec selektiere Audio, stelle als Codec MPEG Audio und als Sample Rate 48000 Hz ein.

    Alle anderen Parameter lässt Du unverändert und speicherst das Profil über die Taste Erstellen.


    Nun musst Du noch Dein erstelltes Profil auswählen. Dann kannst Du den ersten Versuch machen.


    Funktioniert es nicht, probierst Du Dein Profil der Reihe nach mit folgenden Einstellungen für den Audiocodec aus: MP3 und Vorbis. Nach jeder Änderung den Einstellungsdialog über die Taste Speichern verlassen.


    Funktioniert es mit keiner der vorgeschlagenen Audio-Codec Einstellungen, dann probiere es mit der Original-Audiospur. Dafür im Register für den Audiocodec die Option Audio deselektieren und die Option Originalspur beibehalten selektieren.


    MfG, kodela

  • Hallo,


    alles durchprobiert - Anzeige im VLC mit Ton, abgespeicherte Datei ohne Ton.


    Habe alle genannten Varianten als Profil gespeichert, aber ohne Erfolg.


    Fehlt vielleicht an anderer Stelle ein Setting? Ich befürchte das, denn ich habe ein kurzes Download Video in mp4 versucht und hier war es dasselbe. Abspielen im VLC mit Ton aber transkodieren danach ohne Ton. Gibt's doch nicht, was mache ich falsch?


    viele Grüße
    AJ

  • Hallo,


    gesagt getan - den Folder gelöscht und im Anschluss VLC deinstalliert bzw. den 64 Bit 2.2.4 installiert. Damit kommen andere Videos nach dem speichern mit Ton, aber eben nicht die von der Kamera. Wenn ich eine Mailadresse hätte könnte ich ein kurzes 5 Sekunden Video mit Ton, der Kamera, schicken (8 MB).


    Kann sein dass mit den Einstellungen was schief hing und jetzt mit der Option (Originalspur behalten) wieder funktioniert. Aber - und das war ja das ursprüngliche Problem - nicht der Kameraton.


    viele Grüße
    AJ

  • Hallo akj0815,


    besorge Dir das freie Tool "MediaInfo", öffne damit Deine Quelldatei und lasse Dir über die Menüoption "Ansicht - Text" die Infos dazu zeigen. Speichere diese und füge sie Deiner Antwort als Anhang bei.


    MfG, kodela

  • Ja, hier ist es:

    Allgemein
    Vollständiger Name :
    Format :
    Format-Profil :
    Codec-ID :
    Dateigröße :
    Dauer :
    Gesamte Bitrate :
    Kodierungs-Datum :
    Tagging-Datum :
    Copyright :
    CNTH :
    com.apple.quicktime.make :
    com.apple.quicktime.model :
    com.apple.quicktime.author :


    Video
    ID :
    Format :
    Format/Info :
    Format-Profil :
    Format-Einstellungen für CABAC :
    Format-Einstellungen für ReFrames :
    Format_Settings_GOP :
    Codec-ID :
    Codec-ID/Info :
    Dauer :
    Bitrate :
    Breite :
    Höhe :
    Bildseitenverhältnis :
    Modus der Bildwiederholungsrate :
    Bildwiederholungsrate :
    ColorSpace :
    ChromaSubsampling/String :
    BitDepth/String :
    Scantyp :
    Bits/(Pixel*Frame) :
    Stream-Größe :
    Sprache :
    Kodierungs-Datum :
    Tagging-Datum :
    colour_range :
    colour_primaries :
    transfer_characteristics :
    matrix_coefficients :


    Audio
    ID :
    Format :
    Format-Einstellungen für Endianess :
    Format-Einstellungen für Sign :
    Codec-ID :
    Dauer :
    Bitraten-Modus :
    Bitrate :
    Kanäle :
    Kanal-Positionen :
    Samplingrate :
    BitDepth/String :
    Stream-Größe :
    Sprache :
    Kodierungs-Datum :
    Tagging-Datum :
  • Mist sieht man nach dem Abschicken nicht - dann als Text:


    Anmerkung von kodela: Sieht man sehr wohl!



  • Hallo akj0815,


    in Zeile 53 der Infos kannst Du lesen: "Codec-ID : sowt". Dies deutet auf ein bekanntes Problem mit einigen Canon-Kameras hin, bei dem der Audiostream nicht wiedergegeben werden kann.


    Probiere noch einmal folgendes:


    VLC 2.0.8 installieren und unter Einstellungen - Alle - Input/Codecs - Videocodecs - FFmpeg die Größe des Ratenkontroll-Puffers von 0 auf 1 setzen sowie Strikte Standardbefolgung von 0 auf -2 setzen und danach den Einstellungsdialog über die Schaltfläche "Speichern" schließen.


    Nach einem Neustart im Profil MKV für die Verkapselung und MPEG 4 Audio (AAC) für den Audiocodec einstellen.

  • Hallo,


    so alle anderen deinstalliert und den 2.0.8 installiert. Änderungen unter Einstellungen gemacht und dann das Profil konfiguriert. Erst gab es noch eine Fehlermeldung und dann habe ich als Videocodec H-264 und beim Audiocodec die 48000 Abtastrate gesetzt. Dann kam auch ein Video mit Ton raus! Zwar etwas komisch, denn kein Vorschaubild im Dateiexplorer und man kann im Mediaplayer nicht im Video vorspringen, aber egal ich hab den Ton und meine Änderung in Gamma und Schärfe. Damit kann ich das Video geändert weiter verarbeiten. Super und Danke für die Geduld!


    viele Grüße
    AJ