deinterlaced konvertieren aber in "bob" mode?

  • Das Thema deinterlacing und deinterlaced Abspielen von DV Dateien ist ja schon viel besprochen worden, meine Frage ist jedoch wie man beim konvertieren im VLC Spieler nicht nur "deinterlacing" sondern zusaetzlich auch noch den "bob mode" waehlen kann. Denn was ich herrausgefunden habe ist dass "bob" das einzig ware ist. Im VLC Spieler kann man wie erwaehnt zwar deinterlaced konvertieren und die Datei dann speichern, aber ohne bob wackelt immer noch alles.... Habe VirtualDub ausprobiert, das ist aber viel zu umstaendlich und hat ehrlich gesagt auch nicht funktioniert. Konvertieren und Speichern so wie ein Film beim Anschauen im VLC Spieler under "deinterlaced > bob" dargestellt wird ist mein Ziel... Bin fuer jeden Tip dankbar

  • Hallo stevenchina,


    Du schreibst:

    Quote

    ... Im VLC Spieler kann man wie erwaehnt zwar deinterlaced konvertieren und die Datei dann speichern, ...


    Frage: Wo hast Du erwähnt, dass man im VLC media player deinterlaced konvertieren und die Datei dann speichern kann? Ich gehe einmal davon aus, Du meinst speichern als "deinterlacede" Videodatei, also als Videodatei mit 50 Vollbildern pro Sekunde.


    Falls ich da was überlesen haben sollte, gleich noch die Frage, wie das gehen soll.


    Mit freundlichem Gruß,


    kodela

  • Hallo kodela,


    das "wie erwaehnt" war auf einen frueheren Forumeintrag bezogen (evtl auch auf einer anderen website). Ist ja auch nebensaechlich. Die Frage ist zur folgenden Prozedur (ich nutze VLC in englisch):


    Media > convert/save > "add...." > convert/save > bei den settings Haken in deinterlace setzen und output file format waehlen > chose destination file > Start.


    Dann hast Du die Datei deinterlaced aber leider ohne "bob"....

  • Hallo stevenchina,


    ok, Du hast, falls Du die Option "deinterlace" setzt, als Mode nicht "Bob" sondern standardmäßig "Blend".


    Das kannst Du ändern und zwar so:


    Einstellungen - Video - Filter - Deinterlace - Streaming-Deinterlace-Modus = Bob


    Die Frage ist nur, was es Dir bringt. Du kannst es ohne Deinterlace speichern und beim Abspielen Deinterlace im Bob-Mode setzen. Das Ergebnis dürfte das Selbe sein.


    Mit freundlichem Gruß,


    kodela

  • Hallo kodela,


    das mit dem Abspeichern des deinterlacing mode "bob" in den Einstellungen hilft schon mal sehr wenn man die Filme abspielen moechte, ohne diese Einstellung jedesmal manuell neu anwahlen zu muessen. Besten Dank fuer diessen Tip. Es geht aber weiter...


    ...und zwar ist es ja mein Ziel die Filme deinterlaced in bob mode konvertiert und gespeichert zu haben, da ich ja aus meinen vielen einzelnen Filmen, einen grossen Film zuschneiden und bearbeiten moechte um alle dann letztendlich als DVD Film zu haben. Egal mit welchem player der dann spaeter abgespielt wird, sollte dabei nichts mehr wackeln. Ich MUSS die Einzelfilme VOR dem Bearbeiten (z.B. im VideoPad Video Editor) deinterlaced in bob mode haben, damit sie eben nicht mehr "wackelig" sind. Ansonsten bleibt der letztendliche Film auch wackelig und dann hilft beim Abspielen der VLC player auch nicht mehr weil die Dateien sich nicht mehr deinterlacen lassen nachdem sie mal bearbeitet, zusammengeschnitten und erneut z.B. als .avi abgespeichert wurden.


    Ich habe das Konvertieren und Speichern mit "Deinen Einstellungen" erneut versucht aber es wackelt immer noch alles. Anscheinend dient "deinterlacing bob" wirklich nur dem Abspielen und nicht dem Konvertieren.


    Ueber weitere tips bin ich jederzeit dankbar.


    Gruss aus China

  • Hallo stevenchina,


    entschuldige bitte, ich habe in meiner letzten Antwort vergessen, darauf hinzuweisen, dass Du in

    Einstellungen - Alle - Video - Filter

    Die Option Video-Deinterlacefilter selektieren musst, also dort muss in das Kontrollkästchen ein Häkchen gesetzt werden.


    Damit wird beim Konvertieren dieser Filter angewandt und Du hast die gespeicherten Dateien so, wie Du sie willst.


    Ich frage mich nur, was Dir das bringt. Ich schneide nun selbst schon seit zehn Jahren Videos und brenne DVDs, aber Dein Problem hatte ich noch nie. Jedes Frame wird aus den zwei Halbbildern zusammengesetzt und alle mir bekannten Player setzen bei der Wiedergabe ungefragt das Deinterlacing ein, ausgenommen VLC. Aber auch VLC kann so konfiguriert werden, dass Deinterlacing generell verwendet wird.


    Was ich weiter nicht verstehe, dass Du im Zusammenhang mit Deinterlacing immer wieder von "Wackeln" sprichst. Durch Deinterlacing wird bei schnellen Bewegungen das Zeilenflimmern verhindert, sonst aber auch gar nichts. Sollte ich mich da täuschen, lasse ich mich gerne eines Besseren belehren.


    Mit freundlichem Gruß,


    kodela

  • Hallo kodela,


    ich sehen schon Du hast mit der Sache viel Erfahrung und es freut mich dass ich dank Deiner Hilfe schon ein gutes Stueck weiter gekommen bin.


    Mit den Einstellungen fuers Abspielen ist nun alles klar und die Filme lassen sich schoen ansehen. Mit "Wackeln" meine ich das was Du richtig beschrieben hast, die Verzerrungen (Zeilenflimmern) die man nunmal bei den Aufnahmen mit jeder DVC hat. Deine Aussage dass dies aber automatisch von jedem Player deinterlaced wird kann ich leider nicht teilen. Zumindest nicht in der Qualitaet wie es der VLC Player im deinterlace mode Bob tut. Der originale Film sieht z.B. im Media Player genau so schlecht aus wie im VLC Player ohne deinterlacing. Aber lassen wir das mal so dahingestellt. Wie gesagt, ich moechte ja nicht nur deinterlaced schauen sondern konvertiert speichern.


    Du erwaehnst eine weitere Einstellung bei: Einstellungen - Alle - Video - Filter , - Die Option Video-Deinterlacefilter zu selektieren. Wenn ich in diesem Menue bin sehe ich keine Moeglichkeit dort ein Haeckchen zu setzen weil es kein Kaestchen gibt (VLC Player Version 2.0.4). Ich sehe lediglich das was ich auf dem screenshot im Anhang "deinterlace filter.jpg" zeige. Ich kann jetzt bei streaming deinterlace mode von blend auf bob wechseln, was ich auch getan habe. Dann habe ich einen Testfilm konvertiert wie auf den drei Fotos "convert pic 01 - 03" zu sehen ist. Das Resultat ist nicht zufriedenstellend. Die Qualitaet des konvertierten Filmes ist weit von der Qualitaet entfernt, welche man im reinen Abspielmodus "deinterlaced mit Bob" hat.


    Gerne lese ich wieder von Dir.


    Gruss, stevenchina

  • Hallo stevenchina,


    Du schreibst:

    Quote

    Du erwaehnst eine weitere Einstellung bei: Einstellungen - Alle - Video - Filter, - Die Option Video-Deinterlacefilter zu selektieren.

    Warum suchst Du die Option Video-Deinterlacefilter nicht dort, wie ich es beschrieben habe, also unter Einstellungen - Alle - Video - Filter?


    Dein Bild stammt aus dem Abschnitt Einstellungen - Alle - Video - Filter - Deinterlace!


    Ich zitiere mich ausnahmsweise einmal selbst:

    Quote

    entschuldige bitte, ich habe in meiner letzten Antwort vergessen, darauf hinzuweisen, dass Du in


    Einstellungen - Alle - Video - Filter


    die Option Video-Deinterlacefilter selektieren musst, also dort muss in das Kontrollkästchen ein Häkchen gesetzt werden.

    Mit freundlichem Gruß,


    kodela

  • Hallo kodela,


    gut, hast recht, hab mich wohl verlesen, und den Fehler korrigiert. Habe das von Dir erwaehnte setting gefunden und ein Haekchen unter der Liste "Video Filter Module" bei Deinterlacing Video Filter gesetzt, da ich das wortwoertlich von Dir erwaehnte Video-Deinterlacefilter dort nicht finden kann. Danach konvertierte ich meinen Testfilm... mit negativem Resultat. Dann fand ich unter der Liste "Video splitter module" auch die Option Deinterlacing Video Filter, hab dort auch ein Haekchen gestetz, hab nochmal konvertiert, und passt immer noch nicht....


    Gerne lese ich wieder von Dir, besten Dank und schoenen Sonntag,


    stevenchina

  • Hallo stevenchina,


    Du schreibst:

    Quote

    Habe das von Dir erwaehnte setting gefunden und ein Haekchen unter der Liste "Video Filter Module" bei Deinterlacing Video Filter gesetzt, da ich das wortwoertlich von Dir erwaehnte Video-Deinterlacefilter dort nicht finden kann.

    Frage: Soll ich jedes Mal, nur weil Du VLC in englisch nutzt, ich zitiere Dich: "(ich nutze VLC in englisch)" bei mir die Spracheinstellung von Deutsch auf Englisch umstellen, damit Du nicht übersetzen musst?


    Nun aber zur Sache: Aus Deinen beiden (identischen) Bildern habe ich gesehen, dass bei Dir der "Bildeigenschaftsfilter", in englisch (weil ich es aus Deinen Bildern sehe) "Image properties filter" nicht selektiert ist. Der muss als Voraussetzung für alle anderen Filter dieser Gruppe ebenfalls gesetzt werden.


    Da gibt es in diesem Abschnitt noch eine ähnliche Option, zu Deutsch "Video-Nachearbeitungsfilter". Diese ist zwar bei mir nicht gesetzt und es funktioniert trrotzdem. Vermutlich kann man aber diese Option auch oder zusätzlich an Stelle der Option "Bildeigenschaftsfilter", das ist deutsch, setzen.


    Mit freundlichem Gruß,


    kodela

  • Danke koleda,


    und sorry fuer die Umstaende, ich kenne nunmal VLC Player und viele andere Programme in der englischen Sprache besser als auf deutsch da ich ueber 14 Jahre in China lebe und arbeite und alles hier auf englisch ueberwiegend besser ablaeuft. Ich habe nun meinen VLC Player auf deutsch umgestellt. Meine Kommentare dienen nicht dazu Deine Fachkenntnisse anzuzweifeln, sonder nur die Tatsachen zu beschreiben.


    ....und ich habe jetzt die Einstellungen so gesetzt wie Du mir es gesagt hast. Die zwei Bilder von vorher waren nicht identisch weil es einmal das Videofilter-Modul und einmal das Video-Splitter Modul darstellte.


    Jetzt bitte ich Dich die Einstellung auf dem angehaengten Foto anzuschauen. Ich habe bereits wieder einmal konvertiert, inklusive Haekchen auf Bildeigenschaftsfilter und dann nochmal mit Haekchen auf Video-Nachbearbeitungsfilter, und leider (wirklich leider) ist der konvertierte Film wieder nicht so gut als im Abspielmodus "deinterlaced mit Bob".


    Irgendwo fehlt vielleicht noch ein Haekchen?


    Es ist morgens um halb 1 bei mir, lese in den naechsten Tagen von Dir, Gruss aus Shanghai,


    stevenchina

  • Hallo stevenchina,


    Du schreibst:

    Quote

    Meine Kommentare dienen nicht dazu Deine Fachkenntnisse anzuzweifeln, ...

    Zur Klarstellung, ich habe im Zusammenhang mit der Videobearbeitung im allgemeinen und dem VLC Player im besonderen keinerlei Fachkenntnisse. Meine Kenntnisse sind die eines interessierten Laien mit etwas Erfahrung in der Videobearbeitung.


    Nun aber zum Thema: Zuerst einmal zwei Frams, beide vom VLC Player ohne Deinterlacing. Das erste direkt aus der Datei mit dem Original-Video, das zweite von einer gespeicherten Kopie des Originals, wobei der Deinterlacing-Filter im Modus Bob eingesetzt wurde:


    Original:
    interlacing_1.jpg


    Kopie mit Deinterlacing-Filter:
    interlacing_2.jpg


    Beide Frames zeigen die selbe Situation eines relativ schnellen Schwenks und für beide, Original und Kopie, sehen alle folgenden Frames prinzipiell genau so aus; also im Original mit den sichtbaren Zeilenstreifen und in der Kopie ohne diese.


    Wie diese diese Kopie erzeugt wurde:


    Original-Video (MPG-Datei) in die Wiedergabeliste genommen.
    Über Kontextmenü Option "Speichern..." gewählt.
    Im Dialogfenster "Konvertieren" Zieldatei festgelegt, ohne Dateiendung explizit einzutragen.
    Als Profil das Default-Profil "Video - H.264 + MP3 (MP4)" belassen.
    Option "Deinterlace" selektiert.
    Über den Button "Start" Konvertierung gestartet.


    Nach der Konvertierung hatte ich die Kopie mit der Namenserweiterung ".ps", die vom VLC Player angenommen wird, jedoch zum Beispiel nicht von meinem Schnittprogramm "Magix videodeluxe 17", in ".mp4" umbenannt, was ja auch dem angewandten Konvertierungsprofil entspricht.


    Folgende Einstellungen in VLC waren gesetzt:


    Video - Filter: nur für Videofilter-Modul "Video-Deinterlacingfilter"
    Video - Filter - Deinterlace: Streaming-Deinterlace-Modus="Bob"


    Zusätzliche Hinweise:


    Bei Erstellung einer Kopie über den Aufnahme-Button wird kein Filter angewandt!
    Das Deinterlacing funktioniert auch mit anderen Konvertierungsprofilen.



    Mit freundlichem Gruß


    kodela


    Anlass der nachträglichen Bearbeitung: Konkretisierung der angegebenen Einstellung in Video - Filter

  • Hallo kodela,


    das habe ich jetzt alles genauso durchgespielt und siehe da, wenn ich den konvertierten Film im VLC Player abspiele (natuerlich deinterlaced in bob mode) dann schaut er auch gut aus, in einem anderen Player aber nicht. Genauso erfolglos ist dann auch der kurz bearbeitete und neu abgespeicherten Film im VideoPad Video Editor, da der vorher konvertierte Film anscheinend doch nicht deinterlaced war.


    Ich denke ich brauch von der Sache mal ne Pause, es gibt evtl noch ein anderes setting oder codec oder was weis ich was da noch helfen kann.


    Ach ja, hast Du Deinen konvertierten Film auch in einem anderen Player abgespielt oder nur im VLC?


    Gruss,


    stevenchina

  • Hallo stevenchina,


    ja, eine Denkpause wirkt oft Wunder. Jetzt aber zu Deiner Frage, ob ich den konvertierten Film auch in einem anderen Player oder nur im VLC abgespielt habe:


    Ja, in PowerDVD und im PDVDLaunchPolicy wurde das über den Deinterlacing-Filter konvertierte Videoschnipsel mit unakzeptable Mängel wiedergegeben, der Windows Mediaplayer unterschlug die ersten zehn Sekunden und mein Video-Schnittprogramm (Videodeluxe) behandelte Original- und gefilterte Version absolut gleich.


    Man wird sich fragen müssen, ob und wann deinterlaced Videomaterial iinteressant oder wichtig ist. Für mich habe ich bisher noch keine Vorteile gesehen. In den von mir selbst erstellten Videos (HD-Qualität mit einer Auflösung von 1920x1080) habe ich bisher noch bei keinem Wiedergabegerät den Streifeneffekt festgestellt, ausgenommen beim VLC Player in der Grundeinstellung, also ohne Deinterlacing.


    Bisher ist es mir übrigens nicht gelungen, hoch auflösende Videos (AVCHD-Material) mit dem VLC Player zu konvertieren.


    Hier habe ich noch einen Link zur Homepage von Bruno Peter Hennekk, den ich als exzellenten Kenner der gesamten Video-Thematik schätze. Auf dieser Page geht es um das Deinterlacen.


    Mit freundlichem Gruß,


    kodela

  • Hallo stevenchina,


    Du hast für das Deinterlacing den Bob-Mode einmal für den besten gehalten. Als ich dann mit den verschiedenen Modes mir die Einzelbilder betrachtete, war ich überzeugt, dass der Bob-Mode jedenfalls besser ist, als der bei VLC standardmäßig eingestellte Angleichen-Mode.


    Diese Ansicht habe ich in der Zwischenzeit revidiert, denn ich musste feststellen, dass es zumindest bei HD-Videos mit dem Bob-Mode in bestimmten Situationen zu einem Flimmern kommt. Beim Angleichen-Mode flimmert es bei den selben Stellen nicht.


    Ganz krass war es bei einem Ziegeldach, vermutlich weil hier relativ viele waagrechte Linien dicht beieinander liegen. Ich habe daraufhin mehrere meiner HD-Videos auf dieses Flimmern überprüft und festgestellt, dass es mit dem Angleichen-Mode in keinem einzigen Fall zu diesem Flimmern kam. Mit dem Bob-Mode trat dieser Flimmer- Effekt dagegen öfters auf.


    Da man über das Deinterlacing ja keinen Schönheitswettbewerb für Einzelbilder gewinnen will, ist der bei VLC standardmäßig eingestellte Angleichen-Mode meiner Ansicht nach eindeutig die bessere Einstellung. Einzige Ausnahme sehe ich, wenn man von einem Video Schnappschüsse machen will. Hier hat der Bob-Mode die Nase vorne.


    Mit freundlichem Gruß,


    kodela